ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

Page auto-scroll 'bouncing around'


#1

So, many times throughout my use of ERPNext, on virtually all pages, my page(s) will jump up or down seemingly randomly. In what I assume is to help me to get to fields that are required, however, in my case, I really loathe it. For example, if I’m halfway down an Item page and I click on the box to use serial numbers, often times instead of ticking the box, it jumps back to the top of the page and I have to scroll down again to check the box. Is there any way in global settings to disable this function? If not, can I do it manually and request it be a global settings option?


#2

I have the same experience. I have found it gets “worse” if you have a lot of caches in your browser. Clearing out history seems to make it better for some time. This is on of my pet peeves with this platform is there are some really weird quirks with the UI that the main developers seem to ignore.


#3

Have same problem using Firefox, and till now didn’t reach any solution.
Please if anyone has a solution share it.


#4

Add me to the affected user. It a hassle to enter date. The issue becomes bigger while using 32" screen. Have cleared cache of Firefox and Chrome but screen keeps bouncing while scrolling.


#5

I´v seen the issue on touch-enabled displays…If you can turn off the touch features, do so and test to see if that’s the culprit


#6

I use Dell 2 in 1 laptop connected to monitor through dock station. Touch is disabled when connected to dock This issue is also on desktop that doesn’t have touch function.


#7

I have a lot of bouncing up and down all the time, in different browsers and different operating systems.

I just want to disable the auto-scroll once and for all. I find it highly irritating anyway, even if it would work…

Does anyone know, how to do that?


#8

As far as we can tell, there are some autoscroll functions in javascript in the core code that causes these ‘jumping’ page issues.

It’s not a browser issue, and disabling the autoscroll etc won’t make any difference as far as we know.

It’s not an easy fix as it affects most modules.


#9

Are there any plans on fixing this issue?


#10

If anyone here could provide step by step instructions of navigating ERPNext and point out the annoying things, I will be willing to fix some of those issues. Animated GIF would be of great help.


#11

This is apparently a sufficiently isolated problem that no resource or initiative can be found to research or report it :slight_smile:


#12

We do have quite a few users affected by this, and although not annoying enough to avoid using ERPNext, it is still a little irritating.
We will try and isolate the main issue and provide some examples on github


#13

This has happened before and isn’t isolated. I think users just tolerate it.

In the instance mentioned at Random scrolling on click, I was not able to get a sufficiently reproducible scenario. There are other similar threads as well.

But it did happen. And it still does happen. It’s just random and not reproducible across systems. This points to something happening with caching, but again, that’s not really reproducible. Which I realize makes it hard to fix.


#14

Just been testing V11 and the issue seems to have been resolved. We haven’t seen any page jumping so far.


#15

Hi, just realised that the bouncing problem has gone on my touch laptop after I had changed Touch Function on chrome://flags.

Came here to share the other post which has the solution.


#16

Hi,

to reproduce the Issues:

  1. Open any document with around 20 or more items in it (Already Saved or create new and save it).
  2. except 1st Item delete all the items.
  3. once the items are deleted, if you try to scroll towards upward, you’ll face this issue.

anyone has other steps to reproduce it, please share it here.


#17

Deleting anything is not necessary. Frankly I have seen this bug since v7 and it has not ever been resolved - it merely sometimes temporarily stops with blind luck.

The simplest steps I can give to reproduce are with the Customize Form:

  1. Open any Form in Customize Form.
  2. In the fields table, open the modal window of any field.
  3. Make changes as wanted, or not. You can simply click around, select and deselect options, or move up and down between fields. In short order the modal window will be entirely off screen if you do not manually scroll to find it due to all the chaotic jumping around.

@Ardan can you provide any specifics since it sounds like you were able to stop it? In my testing here this is still the case as of the v11 beta as well as v12 develop.