ERPNext Conference 2019* Blog

On latest bench update "'Meta' object has no attribute 'nsm_parent_field'"


Traceback (most recent call last):
File “/usr/lib/python3.5/”, line 184, in _run_module_as_main
main”, mod_spec)
File “/usr/lib/python3.5/”, line 85, in _run_code
exec(code, run_globals)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/utils/”, line 97, in
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu/frappe-bench/env/lib/python3.5/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/commands/”, line 25, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/commands/”, line 233, in migrate
migrate(context.verbose, rebuild_website=rebuild_website, skip_failing=skip_failing)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 48, in migrate
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/modules/”, line 41, in run_all
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/modules/”, line 30, in run_patch
if not run_single(patchmodule = patch):
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/modules/”, line 71, in run_single
return execute_patch(patchmodule, method, methodargs)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/modules/”, line 91, in execute_patch
frappe.get_attr(patchmodule.split()[0] + “.execute”)()
File “/home/ubuntu/frappe-bench/apps/erpnext/erpnext/patches/v12_0/”, line 8, in execute
File “/home/ubuntu/frappe-bench/apps/erpnext/erpnext/setup/setup_wizard/operations/”, line 505, in add_dashboards
dashboard_data = get_default_dashboards()
File “/home/ubuntu/frappe-bench/apps/erpnext/erpnext/setup/setup_wizard/data/”, line 7, in get_default_dashboards
company = frappe.get_doc(“Company”, frappe.defaults.get_defaults().company)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 734, in get_doc
doc = frappe.model.document.get_doc(*args, **kwargs)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/model/”, line 69, in get_doc
return controller(*args, **kwargs)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/model/”, line 104, in init
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/model/”, line 149, in load_from_db
super(Document, self).init(d)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/model/”, line 69, in init
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/utils/”, line 187, in setup
if self.meta.nsm_parent_field:
AttributeError: ‘Meta’ object has no attribute ‘nsm_parent_field’

V12.1.0 Bench Update breaking the system “‘Meta’ object has no attribute ‘nsm_parent_field’”

I also updated and got exactly above mentioned error. Please help us to solve.


Am too getting the above mentioned traceback on bench upadte.kindly help me out…!!


Please help us solve this. system is broken


@sahil28297 + @rmehta Getting same error. The system is currently down!

Bench Update ERROR V12.1.0



I am facing same Issue


Panic Level: High :confounded:


How i can go back previous version for example to v12.0.8 ??


You have to go to the erpnext folder (And then the frappe folder) and execute:

git checkout v12.0.8

Error accesing Accounts Receivable

I do that then execute bench migrate i git version 12.0.8 then execute bench restart
I git this when trying login to the system



Try bench migrate again. If it does not work, edit your /sites/SITE_NAME/site_config.json and set maintenance_mode (or something like that) to 0


Go to config folder (cd config) then open common_site_config.json and change value of “maintenance mode”:1 to 0 and save. then do bench restart

“auto_update”: false,
“background_workers”: 1,
"maintenance mode":0
“file_watcher_port”: 6787,
“frappe_user”: “mukane”,
“gunicorn_workers”: 3,
“rebase_on_pull”: false,
“redis_cache”: “redis://localhost:13000”,
“redis_queue”: “redis://localhost:11000”,
“redis_socketio”: “redis://localhost:12000”,
“restart_supervisor_on_update”: true,
“restart_systemd_on_update”: false,
“serve_default_site”: true,
“shallow_clone”: true,
“socketio_port”: 9000,
“update_bench_on_update”: true,
“webserver_port”: 8000
} to {
“auto_update”: false,
“background_workers”: 1,
“file_watcher_port”: 6787,
“frappe_user”: “mukane”,
“gunicorn_workers”: 3,
“rebase_on_pull”: false,
“redis_cache”: “redis://localhost:13000”,
“redis_queue”: “redis://localhost:11000”,
“redis_socketio”: “redis://localhost:12000”,
“restart_supervisor_on_update”: true,
“restart_systemd_on_update”: false,
“serve_default_site”: true,
“shallow_clone”: true,
“socketio_port”: 9000,
“update_bench_on_update”: true,
“webserver_port”: 8000


Thanks, @Nahuel_Nso, @Azhar_Islam
I am now in v12.0.8 until solve the problem in last version


@Nahuel_Nso, @Azhar_Islam
am facing a new problem after login to system all list view is empty and I can’t add new records
like this


Try bench build


Thanks I am grateful for your help and fast response


I get the same error on upgrading. Additional info: I have one site for testing with almost no data in there and, there the error is not shown. Also git checkout v.12.0.8 does work ( cd apps/frappe first ;-))

Kind regards,


Due to time difference, I doubt that there will be a solution to this problem today. I have just restored a previous backup and continuing to work on version 12.0.8.


Fixed with the latest release!