Try ERPNext Buy Support Partners Foundation

NodeJS version recommended for ERPNext

Hello Community,

It is my first post in this forum. I am new to ERPNext. Finally I got the solution installed on CentOS after 3 whole nights of fixing and trials.

I am still founding errors which I believe it is related to NodJS.

I used the easy install script. But I had to install NodeJS version 12 before in order to get the script working without errors.

My question is what is the version of NodeJS that is most compatible with the latest ERPNext version?

Thank you.

While I do not have ERPNext running on CentOs , I will leave this link:

https://github.com/nodesource/distributions/blob/master/README.md

Thank you, Smino for your reply. The provided link is mainly about NodeJS installation instrunctions. My original question is about the version of NodeJS that works best with ERPNext Version 12.X. What it is?

Thank you anyway.

Perhaps this will provide some guidance: https://jwrober.github.io/erpnext_admin_guide/i-u-b/install.html

1 Like

Actually, it is of a very great assistance. I wish I have been referred to this guide From before that would have saved me lot of time.

Thank you very much indeed.