Try ERPNext Buy Support Partners Foundation

No module named 'frappe'

I am trying to install ERPNext on an Ubuntu VPS Server 14.04, I am using this link Guide: Manual Install ERPNext on Ubuntu 16.xx & Debian v8 & 9. when when i tried creating a new site it showed me no command such as new-site. So on research i ran bench setup requirements. that did not solve the problem. I tried bench update and this error shows,

/home/frappe/frappe-bench/env/bin/python: Error while finding spec for ‘frappe.utils.bench_helper’ (<class ‘ImportError’>: No module named ‘frappe’)

please how do i fix this. find sample code below

frappe@server:~/frappe-bench$ bench update
Backing up sites…
INFO:bench.app:pulling frappe
$ git pull upstream develop
From https://github.com/frappe/frappe

  • branch develop -> FETCH_HEAD
    Already up-to-date.
    $ find . -name “*.pyc” -delete
    Updating Python libraries…
    $ /home/frappe/frappe-bench/env/bin/pip install -q -U pip
    DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won’t be maintained after March 2019 (cf PEP 429).
    INFO:bench.app:installing frappe
    $ /home/frappe/frappe-bench/env/bin/pip install -q -U -e /home/frappe/frappe-bench/apps/frappe
    DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won’t be maintained after March 2019 (cf PEP 429).
    ERROR: Could not find a version that satisfies the requirement Faker==2.0.4 (from frappe==12.0.0.dev0) (from versions: 0.0.2, 0.0.3, 0.0.4, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.7.0, 0.7.1, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.7.7, 0.7.8, 0.7.9, 0.7.10, 0.7.11, 0.7.12, 0.7.13, 0.7.14, 0.7.15, 0.7.16, 0.7.17, 0.7.18, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.8.14, 0.8.15, 0.8.16, 0.8.17, 0.8.18, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 4.0.0, 4.0.1, 4.0.2)
    ERROR: No matching distribution found for Faker==2.0.4 (from frappe==12.0.0.dev0)
    Updating node packages…

Installing node dependencies for frappe
$ yarn install
yarn install v1.22.4
[1/4] Resolving packages…
success Already up-to-date.
$ yarn run snyk-protect
yarn run v1.22.4
$ snyk protect
Successfully applied Snyk patches

Done in 4.02s.
Done in 5.03s.
Patching sites…
/home/frappe/frappe-bench/env/bin/python: Error while finding spec for ‘frappe.utils.bench_helper’ (<class ‘ImportError’>: No module named ‘frappe’)