Nginx restart issue

Hello everyone,
Just went through the manual installation of ERPNext v12 on Ubuntu 18.04
Other than an error about dateutils exceeding some current expected version, I haven’t had any unsolvable issues (and so far the dateutils error doesn’t seem to cause any issues, as the services have been working ok so far).

Now I can access ERPNext via my VPS ip address and port 8000. I assume that to access it at port 80, I need to install nginx?
Anyways, I followed the hitchhikers guide directions for installing nginx, and whenever I reach the final step of restarting nginx I get this error:

Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.

$ systemctl status nginx.service
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: en
Active: failed (Result: exit-code) since Thu 2019-11-07 19:24:16 CET; 14s ago
Docs: man:nginx(8)
Process: 1601 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process

any thoughts on why this error is happening?

additionally, if i want to use a subdomain for the ERP, what alterations should I add to my domain’s DNS record?
Finally, how can I ensure access to ERPNext is encrypted? I hear of Lets Encrypt but not sure what steps to take to integrate it with nginx or erpnext.

Thanks!

$ systemctl status nginx.service - needss elevated permissions (ie. sudo)

sudo systemctl restart nginx

Hi How did you resolve this error? i am facing the same issue.

Try updating your Nginx.

This helped me: https://medium.com/@soban1193/upgrading-nginx-to-the-latest-version-on-ubuntu-c0ad9116cf87

Then sudo systemctl nginx restart.

1 Like

@iMoshi - Thank you so much for sharing that link.

I’d been struggling with the issue for a while and had just about given up.

You’ve saved me a tonne of time