ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

New installation failed




root@erp:~# systemd-nspawn
-bash: systemd-nspawn: command not found


Seems like dependancies are not installed
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
dpkg-reconfigure locales

or maybe

echo "LANG=en_US.UTF-8" > /etc/defaults/locale

Make sure package glibc-locale is installed


Generating locales (this might take a while)…
en_US.UTF-8… done
Generation complete.
root@erp:~# locale

can i install now ?


Looks good to me. Try the install (but not as root) :sunglasses:


python --production --user frappe

am i right ??


these lines imply that you are logged in as root instead of as “frappe”. Probably need to exit by 1 level before you run that command


Same Error :disappointed_relieved:

TASK [locale : Check current locale] *******************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: “localectl”, “delta”: “0:00:00.030520”, “end”: “2017-11-12 09:39:40.646618”, “failed”: true, “rc”: 1, “start”: “2017-11-12 09:39:40.616098”, “stderr”: “Failed to create bus connection: No such file or directory”, “stderr_lines”: [“Failed to create bus connection: No such file or directory”], “stdout”: “”, “stdout_lines”: []}
to retry, use: --limit @/tmp/.bench/playbooks/production/install.retry

PLAY RECAP *********************************************************************
localhost : ok=5 changed=2 unreachable=0 failed=1

Traceback (most recent call last):
File “”, line 388, in
File “”, line 114, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 326, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘production/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2


I can only suggest checking your hostname and /etc/hosts files

hostname -a
cat /etc/hostname
cat /etc/hosts
for some problematic entries or something


root@erp:~# hostname -a
root@erp:~# cat /etc/hostname
root@erp:~# cat /etc/hosts
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters localhost.localdomain localhost

Auto-generated hostname. Please do not remove this comment. erp
::1 localhost ip6-localhost ip6-loopback


Try this article…


any other ideas about that issue ??

Installation Failed on Checking Locale TASK (using Install Script)

If you are on ScaleWay then install centos instead of Ubuntu. It worked for me.



Hi, I ran into the same problem and installing dbus fixed the problem for me:

apt-get install dbus


thanks friends


I had the same issue when trying to run ERPNext on Windows Linux Subsystem. Fixed using below commands,

sudo mkdir -p /run/dbus
sudo service dbus start
sudo dbus-daemon --system


hello swadeesh,
can you please share the installation process for Windows Linux Subsystem.


I was able to install only after fixing multiple issues.

Let me know if you are stuck with error. Will see if I had a similar issue and try to provide a solution.


Hello Swadeesh,

I tried more than 5 times with Easy Installation and windows Linux Subsystem(Ubuntu 18.04 lts) every time installation process will reach upto TASK [Create new site] *********************************************************
from then process will not move .so i will clean every thing and i will re-initiate installation process again.

One of my friend suggested me to install erpnext in virtual box . This is amazing the entire installation process took only 20 mins and its going good now.

Thank you,


That’s an easy way of installing, but I was able to get it working on Linux subsystem for Windows.

I can see Windows is moving forward with the bash approach to enable all linux commands. So I feel it would be better to use Linux subsystem instead of a separate software running Linus distro in a virtual environment.