Need Help with post instalation

Hi,
I have installed Erpnext and it has completed successfully.
On bench start I get this message:

    nitin@nitin-Rev-1-0:~$ bench start
14:35:59 system           | redis_socketio.1 started (pid=28888)
14:35:59 redis_socketio.1 | [28895] 01 Apr 14:35:59.344 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
14:35:59 redis_socketio.1 | [28895] 01 Apr 14:35:59.344 # Creating Server TCP listening socket *:12000: bind: Address already in use
14:35:59 system           | redis_socketio.1 stopped (rc=1)
14:35:59 system           | workerbeat.1 started (pid=28891)
14:35:59 system           | watch.1 started (pid=28903)
14:35:59 system           | web.1 started (pid=28900)
14:35:59 system           | worker.1 started (pid=28907)
14:35:59 system           | socketio.1 started (pid=28899)
14:35:59 system           | redis_cache.1 started (pid=28906)
14:35:59 redis_cache.1    | [28914] 01 Apr 14:35:59.422 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
14:35:59 redis_cache.1    | [28914] 01 Apr 14:35:59.423 # Creating Server TCP listening socket *:13000: bind: Address already in use
14:35:59 system           | redis_cache.1 stopped (rc=1)
14:35:59 system           | redis_queue.1 started (pid=28904)
14:35:59 system           | longjob_worker.1 started (pid=28912)
14:35:59 system           | async_worker.1 started (pid=28913)
14:35:59 system           | sending SIGTERM to workerbeat.1 (pid 28891)
14:35:59 system           | sending SIGTERM to worker.1 (pid 28907)
14:35:59 system           | sending SIGTERM to redis_queue.1 (pid 28904)
14:35:59 system           | sending SIGTERM to web.1 (pid 28900)
14:35:59 system           | sending SIGTERM to async_worker.1 (pid 28913)
14:35:59 system           | sending SIGTERM to socketio.1 (pid 28899)
14:35:59 system           | sending SIGTERM to watch.1 (pid 28903)
14:35:59 system           | sending SIGTERM to longjob_worker.1 (pid 28912)
14:35:59 system           | redis_queue.1 stopped (rc=-15)
14:35:59 system           | workerbeat.1 stopped (rc=-15)
14:35:59 system           | worker.1 stopped (rc=-15)
14:35:59 system           | socketio.1 stopped (rc=-15)
14:35:59 system           | longjob_worker.1 stopped (rc=-15)
14:35:59 system           | web.1 stopped (rc=-15)
14:35:59 system           | async_worker.1 stopped (rc=-15)
14:35:59 system           | watch.1 stopped (rc=-15)
nitin@nitin-Rev-1-0:~$ 

after which when i go to localhost:8080, i dont see erpnext start up page.
Am I missing a step here.

Please help.

Thanks
Nitin

Looks like you already have a production setup. To move to development setup, see https://github.com/frappe/bench/wiki/Stopping-Production-and-starting-Development

Hi Anand,
Thankyou for your response:
I am getting the following response:

    nitin@nitin-Rev-1-0:~$ cd frappe-bench
nitin@nitin-Rev-1-0:~/frappe-bench$ rm config/supervisor.conf
rm: cannot remove ‘config/supervisor.conf’: No such file or directory
nitin@nitin-Rev-1-0:~/frappe-bench$ rm config/nginx.conf
rm: cannot remove ‘config/nginx.conf’: No such file or directory
nitin@nitin-Rev-1-0:~/frappe-bench$ sudo service nginx stop
nitin@nitin-Rev-1-0:~/frappe-bench$ sudo service supervisord stop
supervisord: unrecognized service
nitin@nitin-Rev-1-0:~/frappe-bench$ bench setup procfile
nitin@nitin-Rev-1-0:~/frappe-bench$ bench start
15:06:45 system           | redis_socketio.1 started (pid=29896)
15:06:45 system           | web.1 started (pid=29904)
15:06:45 system           | redis_cache.1 started (pid=29910)
15:06:45 system           | socketio.1 started (pid=29907)
15:06:45 system           | workerbeat.1 started (pid=29914)
15:06:45 system           | redis_queue.1 started (pid=29905)
15:06:45 system           | worker.1 started (pid=29906)
15:06:45 redis_socketio.1 | [29899] 01 Apr 15:06:45.276 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
15:06:45 redis_socketio.1 | [29899] 01 Apr 15:06:45.276 # Creating Server TCP listening socket *:12000: bind: Address already in use
15:06:45 system           | redis_socketio.1 stopped (rc=1)
15:06:45 system           | async_worker.1 started (pid=29927)
15:06:45 system           | longjob_worker.1 started (pid=29918)
15:06:45 system           | watch.1 started (pid=29928)
15:06:45 system           | sending SIGTERM to workerbeat.1 (pid 29914)
15:06:45 system           | sending SIGTERM to worker.1 (pid 29906)
15:06:45 system           | sending SIGTERM to redis_queue.1 (pid 29905)
15:06:45 system           | sending SIGTERM to web.1 (pid 29904)
15:06:45 system           | sending SIGTERM to async_worker.1 (pid 29927)
15:06:45 system           | sending SIGTERM to socketio.1 (pid 29907)
15:06:45 system           | sending SIGTERM to redis_cache.1 (pid 29910)
15:06:45 system           | sending SIGTERM to watch.1 (pid 29928)
15:06:45 system           | sending SIGTERM to longjob_worker.1 (pid 29918)
15:06:45 system           | web.1 stopped (rc=-15)
15:06:45 system           | longjob_worker.1 stopped (rc=-15)
15:06:45 system           | redis_cache.1 stopped (rc=-15)
15:06:45 system           | socketio.1 stopped (rc=-15)
15:06:45 system           | workerbeat.1 stopped (rc=-15)
15:06:45 system           | async_worker.1 stopped (rc=-15)
15:06:45 system           | watch.1 stopped (rc=-15)
15:06:45 system           | redis_queue.1 stopped (rc=-15)
15:06:45 system           | worker.1 stopped (rc=-15)

Thanks
Nitin

it seems port 12000 is still runnig.

first try sudo supervisorctl stop all and run bench start. If issue still persist use sudo fuser -k 12000/tcp

1 Like