Try ERPNext Buy Support Partners Foundation

Need help with an error during bench update - No module named 'gitdb.utils.compat'

Dear all,
Can you support me in going over the below error during bench update?

Traceback (most recent call last):
  File "/usr/local/bin/bench", line 11, in <module>
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 2793, in load_entry_point
    return ep.load()
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 2411, in load
    return self.resolve()
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 2417, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/home/erp/.bench/bench/cli.py", line 4, in <module>
    from bench.app import get_apps
  File "/home/erp/.bench/bench/app.py", line 15, in <module>
    import git
  File "/usr/local/lib/python3.6/dist-packages/git/__init__.py", line 38, in <module>
    from git.exc import *                       # @NoMove @IgnorePep8
  File "/usr/local/lib/python3.6/dist-packages/git/exc.py", line 9, in <module>
    from git.compat import UnicodeMixin, safe_decode, string_types
  File "/usr/local/lib/python3.6/dist-packages/git/compat.py", line 16, in <module>
    from gitdb.utils.compat import (
ModuleNotFoundError: No module named 'gitdb.utils.compat'

`

It may help to say what version of ERPNext/Frappe , the operating environment and when the last successful update happened.

Thanks. It was version 12.5

Regards,
Ahmed

Try this. :point_right: pip install --upgrade gitdb2==2.0.6 gitdb==0.6.4

Or python3 -m pip install GitPython==2.1.11

Thanks a lot! this fixed my issue.

While doing bench update I got this warning:

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

frontmatter 3.0.5 requires PyYAML==3.13, but you'll have pyyaml 5.3.1 which is incompatible.
google-api-core 1.22.2 requires google-auth<2.0dev,>=1.21.1, but you'll have google-auth 1.18.0 which is incompatible.

What should I do now in order not to face issues while updating?
Regards,
Ahmed