ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

MySQL 8 over mariaDB 10.3

https://frappeframework.com/docs/user/en/installation#macos-intel-processor explicitly says mariadb@10.3 - I already have MySQL 8 - won’t MySQL 8 do ? Do I need to explicitly install MariaDB ?

ERPNext works with MariaDB only for now. There’s some progress made with making it compatible with PostgreSQL but there’s still some ways to go before that is 100%. But there’s no compatibility with native MySQL that I am aware of.