Try ERPNext Buy Support Partners Foundation

Multiple Issues with V12 Desktop!

Hi ,

To show/hide cards globally, the manual says the following:

It however only seems to work for the individual user and not globally as the manual suggests

Is this a bug or is there some other way to get around this. Any assistance would be greatly appreciated


Still hoping for some guidance here. I want to believe there’s some existing way to hide modules globally since V12 is already in production use

It’s surprising to me that after upgrading an instance, all users have ALL cards appearing on the desk even when they have no permission for any documents within that module


I’m not sure if this has anything to do with it but the instance was upgraded from V10



Migrating environment to python 3 seems to help get the permission based module visibility part working

The global hiding still needs to be looked into though. At least now, not ALL modules are visible to all users


Sorry, I think I mixed things up a bit here. The user I tested with already had the superfluous modules manually restricted. The migration doesn’t solve the issue

We need a way to restrict modules globally and it’s urgent! I’m really surprised V12 was launched without this!

Hi ,

I find it of significant concern that in V12 which is supposedly production-ready, all modules are visible to all users regardless of whether or not they have permissions for any doctype within the modules. I’ve spent days trying to check if it’s just a bug affecting one instance but so far I’ve tried 3 different instances (both new installations and upgrades from previous versions) with the same results

How in the world is anyone using V12 in production? I really would like to know if there’s some work-around that can help bypass this issue… even if it involves custom scripts or tweaking the core code! It’s horrible UX for someone who only interacts with a couple of documents on the system to login and find the screen filled with modules he/she has no business with! …It’s also ridiculous and ineffective to expect a system admin to have to set this individually for each user… it should be dynamically updated based on documents they are permitted to see

I would really appreciate some assistance or pointers here



See also this reported here

I have to agree with @wale’s statement here, it is cumbersome to get the new desk up and running and somehow efficient.

Also, we have noted that hidden cards cannot be reactivated, drop-down arrows are disappearing (How I broke my desktop dropdown menu). This does need urgent attention.

Easy access to doctypes has also been proposed, e.g. in Improving desktop 2.0

Also, changing User > Home Settings in many cases seems to have no impact on the actually shown cards, even with reload, logout/login, …

1 Like


The user manual was incorrect in stating that the Show / Hide cards was global. It was only for the current user.

The ability to globally hide cards was missing. I have opened a PR to fix that.

Regarding hiding modules in which the user doesn’t have access to any DocTypes, it will need another fix.


Hi @netchampfaris

Thanks for clearing the mix up. It’s wonderful to see you’re looking into this. So much appreciated

Kind regards,

Hi @netchampfaris

Trust you’re doing well. Encountering the error below while trying to restrict modules for all users:

Uncaught TypeError: Cannot read property 'get_unchecked_options' of undefined
    at VueComponent.update_global_modules (Desktop.vue?rollup-plugin-vue=script.js:191)
    at frappe.ui.Dialog.primary_action (Desktop.vue?rollup-plugin-vue=script.js:151)
    at HTMLButtonElement.<anonymous> (dialog.js:142)
    at HTMLButtonElement.dispatch (jquery.min.js:3)
    at HTMLButtonElement.r.handle (jquery.min.js:3)

Kindly help check


Hi @netchampfaris

Any chance of fixing this bug soon please? The feature is still not working on the latest update


Same here

When does that happen? Can you send a GIF demonstrating the issue?

I tried restricting modules for all users on my local setup and it worked just fine, on latest develop.

Hi @netchampfaris

Please see below:


ERPNext: v12.2.0 (version-12)
Frappe Framework: v12.0.20 (version-12)


I’m not sure why the gif is getting compressed so much… it’s fine on my local computer! I’ve also put the gif on the Github PR page and it’s properly displaying there:


1 Like