Material Request not found! Cannot delete PO

Hello,

Few weeks ago Erpnext system allowed to create PO without Material Request. But price changed and I cannot make PO Invoice, price should be the same. So I’ll try to delete OLD PO and create just new one or amend (whatever). But now when I try to delete my PO it gives error “Material Request xxxx not found!!!” so i cannot delete it or cancel. Maybe any one could help me?

you can change rate in purchase…

Go to Buying > Setup > Buying Settings

uncheck Maintain same rate throughout purchase cycle and save setting

2 Likes

Thank You, mate. That was helpful and actually very dumb from my side :smiley:

One more issue now. Then i change price in purchase cycle, “TO BILL” status doesn’t disappear even it’s already invoiced. Any ideas how to fix it in proper way?

Reload the page from menu reload.
If still status is To Bill, then please check reference link

can you check Item Table in Purchase Invoice and send screen shot here?
In Purchase Receipt Item, you can find Purchase Order Reference if you created Purchase Invoice From Purchase Order

1 Like

Still the same. After I write Purchase Receipt and Purchase invoice still status “TO BILL". If i press on PO and Invoice button on top, after my above mention procedure, it gives invoice with rest of the amount which was not included in previous Purchase invoice

(To understand my real life situation: I made PO with extra features which increase price for order item. After almost one month supplier told cannot fulfil my needs and manufactured standard item which is cheaper. It’s OK, a lot of things happen in manufacture process. But how to fill all documents to my ERPNEXT? )

Am not sure which table you want to see. Sales invoice for this order is not made yet, but we are talking about Purchase part so i thought maybe you will be interested in Purchase Invoice Item Table.

If I didn’t understood what you requested please, let me know. I’ll do anything to overcome this issue.

@Paul_G Sorry, it was typing mistake, I asked Purchase Invoice Item screen shot to see PO is linked or not.

Don’t know whats the problem, I have tested on local with change in rate, its working fine.

For such cases, you can Stop or Close Purchase Order.

1 Like

I cannot STOP or CLOSE PO that was main issue. I get msg “Material Request xxxx not found!”
Cannot delete PO. Any suggestions how to overcome this ?

How to close or stop PO when MATERIAL REQUEST is missing?

Don’t know why material request is missing? if material request is linked with other doctype then system should not allow to delete material request.

Can you replicate this into demo.erpnext.com

1 Like

After update, same day, I pressed PURCHASE ORDER button on top right SALES ORDER corner and it allowed me go straight to PO without material MATERIAL REQUEST. As I understand it bugged now. How I could debug this issue?

@Paul_G I don’t know, how you deleted Material Request or why its linked if you created PO from Sales Order.

Can you check Purchase Order Item table?
If material request is present in Purchase Order Item, you need to remove it first.

I know it’s impossible to delete linked documents. PO was created straight from SO, but now it bugged and asking for Material Request. It’s clearly bug. Tried to contact ERPNEXT, no answer. :confused:

You can see linked documents here, but it gives me error as above :

Where did you contact? Are you a subscriber?

Hello Rmehta,

I contacted umair@iwebnotes.com. We still have free from long time before, but we decided to create fresh account from new year, and now there are no free option for more than one account so we going to buy one, but first I want to setup it properly, when I was setting my first ERPNEXT account I was totally green in it.

Maybe you could just login to our acc and delete one position of PO? We plan to keep old account like for 2015, so we do not need to transfer all sales to new account.

@Paul_G sure, can you send a request for this on support at erpnext.com

Sorry, this account which I try to fix is free and I cannot send support request. My paid acc is still did not setup, yet. We going to start it from next year. Now I try to fix all 2015 and move on fresh start.

erpacc: ozzmium.erpnext.com
myacc: pg@ozzmium.co.uk
PO (which required to be deleted): OZZ-0507-022

Please, just connect to my ACC and you will see my bugged situation.

I am aware of the issue. The issue is on my list, will send a fix asap.

Thank You for your concern, guys :wink:

Pushed a fix https://github.com/frappe/erpnext/pull/4557