MapiExceptionDuplicateDelivery when sending mails with multiple recipients

We just updated ERPNext to version 12.
Since the upgrade we get an error when sending emails to multiple recipients.
Emails with only one recipients work.
With emails with multiple recipients only 1 mail gets sent and with the rest we get a MapiExceptionDuplicateDelivery error.

smtplib.SMTPDataError: (554, b’5.2.0 STOREDRV.Submission.Exception:StoragePermanentException.MapiExceptionDuplicateDelivery; Failed to process message due to a permanent exception with message The process failed to get the correct properties. 0.35250:56010000, 1.36674:02000000, 1.61250:00000000, 1.45378:02000000, 1.44866:14000000, 1.36674:06000000, 1.61250:00000000, 1.45378:0F000000, 1.44866:0B000000, 1.36674:A1000000, 1.61250:00000000, 1.45378:1E000000, 1.44866:49000000, 1.36674:07000000, 1.61250:00000000, 1.45378:6A000000, 1.44866:00140000, 16.55847:58050000, 17.43559:000000002D040000000000000200000000000000, 20.52176:140FEA890000F01F1F001432, 20.50032:140FEA897017702003005936, 0.35180:40001E32, 255.23226:0A000000, 255.27962:02000000, 255.27962:06000000, 255.27962:A1000000, 255.17082:2B0A0000, 0.27745:1F10E731, 4.21921:2B0A0000, 255.27962:FA000000, 255.1494:03004031, 0.38698:05000780, 7.36354:010000000000010B00000000, 7.36354:010000000000010B05000780, 7.34114:804D47C17A7ED70805000780, 7.59714:7A17F14E7CFA6CC200000000, 4.61464:2B0A0000, 0.48720:09010480, 8.45434:F3CCC57CCCBC234D935FD9C164F37A1F01000003, 5.10786:0000000031352E32302E323533382E3030303A414D36505230374D42353831333A31626261326536372D643935662D346139352D623266342D36626637353537336237633300505230374D42, 7.51330:3498F4EA7A7ED708372D6439, 255.1750:0300B131, 255.27962:07000000, 0.26881:0300080E, 255.21817:2B0A0000, 0.20385:5E000000, 4.28577:2B0A0000, 0.32001:1F10B330, 4.29953:2B0A0000, 0.32768:1400080E, 4.33024:2B0A0000 [Hostname=AM6PR07MB5813.eurprd07.prod.outlook.com]’)

As far as we know by the feedback of Microsoft (O365) it has to do with the way the application sends the emails.
It looks like they are sent as exact copys of the same email (same ID) witch triggers a block from O365.

Any had this as well, or knows how to solve this?