Manufacturing BOM

Hi,

This is my first time using manufacturing module. I’m trying to create BOM for an item, which consist of few other items. When I go to the Manufacturing page, the “Bill of Materials” is not there. There only “Item” and Production order.

Is there specific condition for this option to be enabled? I confirmed my user has role and access to everything.

Check your domain settings to see if Manufacturing is checked

Hi Pawan,

Yes, manufacturing and service domain are selected.

Try to search for “BOM” in the search bar and also try “reload” (Ctrl+Shift+R)

Hi Pawan,

I tried all those. Searching “BOM” only return the help page. Seems like
the manufacturing module is not there at all.

Hi,

At the installation, you go through the wizard without checking manufacturing, right?

Hi,

Maybe. I cant remember since I setup this few months ago. Anyway to
overcome this?

As others have pointed out, first check if the Manufacturing is selected in the domain settings.

Also, check if you are assigned Manufacturing User and/or Manufacturing Manager roles in your User Settings.

Hi,

As mentioned before, the manufacturing domain is already selected.

Since you mentioned it, there is NO manufacturing manager role available
for me to choose. Its just not there.

Do I missed something here?

In My Settings

If you can’t see the settings you need to contact the system manager or the admin who can apply these settings for you.

Hi,

Sadly I am the system manager. Can you be more specific how to add this?

Thank you

Go to My Settings and check the Roles section.

Hi,

Like I mentioned before, the manufacturing manager role is not there. I’m
already on the latest versionof frappe and erpnext. What else did I missed
out?

I found the problem. The manufacturing user and manufacturing manager role was disabled. Eventhough I selected “manufacturing” in the company domain setting, these two roles are not enabled. I have to manually go to Setup --> Role and enable these two roles. And then go to my user setting and check the roles.

Is this also a bug? Does selecting manufacturing domain suppose to enable the respective roles automatically?