Try ERPNext Buy Support Partners Foundation

Manual bench install error - what's this no Ruby required?

bench --version
Traceback (most recent call last):
2: from /usr/bin/bench:5:in <main>' 1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:inrequire’
/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require’: cannot load such file – bundler (LoadError)

“Maual bench install error”

For some reason your install requires or uses Ruby 2.5?

What install notes did you follow?

here first:


then here

You seem to have an environment issue?

For comparison a ‘vanilla’ ERPNext environment does not require Ruby so these report no ruby packages present

frappe@ubuntu:~/frappe-bench$ sudo apt list --installed | grep ruby
frappe@ubuntu:~/frappe-bench$ sudo apt list --installed | grep Ruby

1 Like

what is this command then I have it in my history is this not needed and can be uninstalled:
sudo apt install ruby-active-model-serializers

Yes probably some misstep where apparently you installed ruby-active-model-serializers at some prompt when that was not called for?

A search on ‘ruby-active-model-serializers’ has good advice just to reinstall

not sure what you are suggesting here is a post I found do we need ruby-active-model-serializers or not?

ok to recap for you: A basic ERPNext install does not require or use Ruby.

So if you are prompted to install ruby-active-model-serializers, then your ERPNext install is in error.

Exactly what error you committed I don’t know.