Try ERPNext Buy Support Partners Foundation

Login doesn't work after install successful

I have done the production installation on my local host & the install finish with no error, after install the page opened plank just home button on the left & the login button on the right & login button didn’t give any responding.
I try many browser & clear cache & history, the same problem still found.
chrome console show this error when i push the login

“GET http://------------/assets/css/frappe-web.css
login:380 GET http://------------/assetse/js/erpnext-web.min.js
login:377 GET http://------------/assets/js/frappe-web.min.js
login:377 GET http://------------/assets/js/frappe-web.min.js
login:380 GET http://------------/assets/js/erpnext-web.min.js 404 (Not Found)
login:572 Uncaught ReferenceError: __ is not defined
at login:572
at login:577
(anonymous) @ login:572
(anonymous) @ login:577”

Please help me as soon as possible.
Thanks

1 Like

@Mohamed.Soliman,
Try the following command:
bench build ,
bench migrate & bench clear-cache

Thanks

@sagar
I get this massage "administrator@ERP-Server:~$ bench build ,
Usage: bench [OPTIONS] COMMAND [ARGS]…

Error: No such command “build”.
administrator@ERP-Server:~$ bench migrate & bench clear-cache
[1] 20381
Usage: bench [OPTIONS] COMMAND [ARGS]…

Error: No such command “migrate”.
Usage: bench [OPTIONS] COMMAND [ARGS]…

Error: No such command “clear-cache”.
[1]+ Exit 2 bench migrate
administrator@ERP-Server:~$
"

try this command in frappe-bench directory.

Thanks

I also have same issue but unable to solve it

@sagar
I got this replay
"administrator@ERP-Server:/home/frappe/frappe-bench$ bench build
module.js:471
throw err;
^

Error: Cannot find module ‘babel-core’
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/home/frappe/frappe-bench/apps/frappe/frappe/build.js:3:15)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
administrator@ERP-Server:/home/frappe/frappe-bench$ bench migrate & bench clear-cache
[1] 20497
Migrating site1.local
Updating DocTypes for frappe : [========================================]
Updating DocTypes for erpnext : [========================================]
Syncing help database…
"

npm install babel-register

Thanks

@sagar
Thanks for your replay sir. but i got this
"administrator@ERP-Server:/home/frappe/frappe-bench$ npm install babel-register
npm WARN checkPermissions Missing write access to /home/frappe/frappe-bench/node_modules
/home/frappe/frappe-bench
├── ansi-regex@2.1.1
├── ansi-styles@2.2.1
├─┬ babel-code-frame@6.22.0
│ ├─┬ chalk@1.1.3
│ │ ├── escape-string-regexp@1.0.5
│ │ ├── has-ansi@2.0.0
│ │ ├── strip-ansi@3.0.1
│ │ └── supports-color@2.0.0
│ ├── esutils@2.0.2
│ └── js-tokens@3.0.1
└─┬ babel-core@6.24.1
├─┬ babel-generator@6.24.1
│ ├─┬ detect-indent@4.0.0
│ │ └─┬ repeating@2.0.1
│ │ └─┬ is-finite@1.0.2
│ │ └── number-is-nan@1.0.1
│ ├── jsesc@1.3.0
│ └── trim-right@1.0.1
├── babel-helpers@6.24.1
├── babel-messages@6.23.0
├─┬ babel-register@6.24.1
│ ├── core-js@2.4.1
│ ├─┬ home-or-tmp@2.0.0
│ │ ├── os-homedir@1.0.2
│ │ └── os-tmpdir@1.0.2
│ ├─┬ mkdirp@0.5.1
│ │ └── minimist@0.0.8
│ └── source-map-support@0.4.15
├─┬ babel-runtime@6.23.0
│ └── regenerator-runtime@0.10.5
├── babel-template@6.24.1
├─┬ babel-traverse@6.24.1
│ ├── globals@9.17.0
│ └─┬ invariant@2.2.2
│ └── loose-envify@1.3.1
├─┬ babel-types@6.24.1
│ └── to-fast-properties@1.0.3
├── babylon@6.17.1
├── convert-source-map@1.5.0
├── json5@0.5.1
├── lodash@4.17.4
├─┬ minimatch@3.0.4
│ └─┬ brace-expansion@1.1.7
│ ├── balanced-match@0.4.2
│ └── concat-map@0.0.1
├── path-is-absolute@1.0.1
├── private@0.1.7
├── slash@1.0.0
└── source-map@0.5.6

npm WARN enoent ENOENT: no such file or directory, open ‘/home/frappe/frappe-bench/package.json’
npm WARN frappe-bench No description
npm WARN frappe-bench No repository field.
npm WARN frappe-bench No README data
npm WARN frappe-bench No license field.
npm ERR! Linux 4.4.0-21-generic
npm ERR! argv “/usr/bin/nodejs” “/usr/bin/npm” “install” “babel-register”
npm ERR! node v6.10.3
npm ERR! npm v3.10.10
npm ERR! path /home/frappe/frappe-bench/node_modules
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall access

npm ERR! Error: EACCES: permission denied, access ‘/home/frappe/frappe-bench/node_modules’
npm ERR! at Error (native)
npm ERR! { Error: EACCES: permission denied, access ‘/home/frappe/frappe-bench/node_modules’
npm ERR! at Error (native)
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘access’,
npm ERR! path: ‘/home/frappe/frappe-bench/node_modules’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.
npm ERR! Linux 4.4.0-21-generic
npm ERR! argv “/usr/bin/nodejs” “/usr/bin/npm” “install” “babel-register”
npm ERR! node v6.10.3
npm ERR! npm v3.10.10
npm ERR! path npm-debug.log.2975584079
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall open

npm ERR! Error: EACCES: permission denied, open ‘npm-debug.log.2975584079’
npm ERR! at Error (native)
npm ERR! { Error: EACCES: permission denied, open ‘npm-debug.log.2975584079’
npm ERR! at Error (native)
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘open’,
npm ERR! path: ‘npm-debug.log.2975584079’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR! /home/frappe/frappe-bench/npm-debug.log

"

add sudo to the command

sudo npm install babel-register

@PyJumper
Thanks sir for your replay, but i got this massage
"administrator@ERP-Server:/home/frappe/frappe-bench$ sudo npm install babel-register
[sudo] password for administrator:
/home/frappe/frappe-bench
├── ansi-regex@2.1.1
├── ansi-styles@2.2.1
├─┬ babel-code-frame@6.22.0
│ ├─┬ chalk@1.1.3
│ │ ├── escape-string-regexp@1.0.5
│ │ ├── has-ansi@2.0.0
│ │ ├── strip-ansi@3.0.1
│ │ └── supports-color@2.0.0
│ ├── esutils@2.0.2
│ └── js-tokens@3.0.1
└─┬ babel-core@6.24.1
├─┬ babel-generator@6.24.1
│ ├─┬ detect-indent@4.0.0
│ │ └─┬ repeating@2.0.1
│ │ └─┬ is-finite@1.0.2
│ │ └── number-is-nan@1.0.1
│ ├── jsesc@1.3.0
│ └── trim-right@1.0.1
├── babel-helpers@6.24.1
├── babel-messages@6.23.0
├─┬ babel-register@6.24.1
│ ├── core-js@2.4.1
│ ├─┬ home-or-tmp@2.0.0
│ │ ├── os-homedir@1.0.2
│ │ └── os-tmpdir@1.0.2
│ ├─┬ mkdirp@0.5.1
│ │ └── minimist@0.0.8
│ └── source-map-support@0.4.15
├─┬ babel-runtime@6.23.0
│ └── regenerator-runtime@0.10.5
├── babel-template@6.24.1
├─┬ babel-traverse@6.24.1
│ ├── globals@9.17.0
│ └─┬ invariant@2.2.2
│ └── loose-envify@1.3.1
├─┬ babel-types@6.24.1
│ └── to-fast-properties@1.0.3
├── babylon@6.17.1
├── convert-source-map@1.5.0
├── json5@0.5.1
├── lodash@4.17.4
├─┬ minimatch@3.0.4
│ └─┬ brace-expansion@1.1.7
│ ├── balanced-match@0.4.2
│ └── concat-map@0.0.1
├── path-is-absolute@1.0.1
├── private@0.1.7
├── slash@1.0.0
└── source-map@0.5.6

npm WARN enoent ENOENT: no such file or directory, open ‘/home/frappe/frappe-bench/package.json’
npm WARN frappe-bench No description
npm WARN frappe-bench No repository field.
npm WARN frappe-bench No README data
npm WARN frappe-bench No license field.
administrator@ERP-Server:/home/frappe/frappe-bench$

"

try
sudo npm install -g babel-register

and
bench build
bench migrate & bench clear-cache

Did you fix it ?

the first command run with no error , but the second got this error
"administrator@ERP-Server:/home/frappe/frappe-bench$ bench build
module.js:471
throw err;
^

Error: Cannot find module ‘less’
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/home/frappe/frappe-bench/apps/frappe/frappe/build.js:4:14)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
"

now other module is required ‘less’ you can install it by:
sudo npm install -g less

and keep doing this if other module required.
but i recommenced that you start fresh installation again.

I’m already reinstall the server from start, but i got the same result, the home page didn’t work, even the login button.

I got this massage in the chrome console when i press on login button:
“GET http://----------------/assets/css/frappe-web.css
login:377 GET http://---------------/assets/js/frappe-web.min.js
login:380 GET http://----------------/assets/js/erpnext-web.min.js
login:377 GET http://--------------------/assets/js/frappe-web.min.js
login:380 GET http://--------------------/assets/js/erpnext-web.min.js 404 (Not Found)
login:572 Uncaught ReferenceError: __ is not defined
at login:572
at login:577
(anonymous) @ login:572
(anonymous) @ login:577”

@Mohamed.Soliman I also got the same error (no login screen) when I made a fresh installation. Apparently some dependancies were not included in that build and hence it broke. I managed to install babel dependancies and but also had to replace missing files (you can check them in browser console). You may have to wait for it to be rectified in the next build.

The system has been work good, I reinstall the Ubuntu server 16.04 with GUI edition & reinstall the system.
Thanks for all for your support.