Try ERPNext Buy Support Partners Foundation

Local Docker Deployment

i think the volume is loaded properly

Sitename is I also tried making entry in the /etc/hosts in the below fashion. Is it the correct way?


Note: I am working on windows system and running these command on git bash.

I have made the above entry in the etc/hosts for the sitename. But still not able to access it. It would be great if you could let me know the probable cause.

Since i could only post a single image in one comment… Here is my env-local screenshot

Please have a look and provide your input

I don’t have windows setup.

I think windows etc host is in system32/64 directory?

I have added the site name in etc/hosts, in my previous comment…but unfortunately i am still not able to access it. Could you suggest why it might be happening?

If you’re using windows I searched Google and found this gist:

I don’t know much about windows. I’ve not used docker on windows or Mac.

Use the above gist as reference. Read comments under the gist. I’ve not tried anything, I don’t have windows.

I have a remote Ubuntu server as well, if i follow the same steps on the server, will i be able to access it remotely though the site name or we will have to do some additional changes in order to access it remotely.

What I can think of:

  1. The server must have static IP
  2. The dns config for site must be set. E.g. if ip is then A NAME must point to this ip and host set as the site domain name. ->
  3. Copy and use env-production instead of env-local, it has the needed traefik labels to use https in production.

Hope it works! Post here if something fails, I can help you on Linux more than any other os.

Also, if possible I’ll recommend using Docker swarm setup with portainer even in single server. It gives nice gui to control the server without connecting to ssh. Ignore this docker swarm if it’s too much for first time, explore it after you’re familiar with Docker.

I am trying the below steps on my ubuntu server:

  1. git clone
  2. cd frappe_docker
  3. cp env-production .env (with changes to sitenames)
  4. docker-compose --project-name erpnext up -d
  5. docker logs erpnext_site-creator_1 -f

Before following the steps I have update the /etc/hosts and env-production as below:

Unfortunately still not able to access the url from remote system.
Please let me know if i missed anything.

I don’t know, may be use correct LETSENCRYPT_EMAIL, I think is not allowed by letsencrypt to be used as email.

I just purchased DO droplet, set my DNS on godaddy, installed erpnext with above commands and everything worked for me.

I’m generally lucky with all types of installations, not just ERPNext.


Hi! I am setting up frappe/erpnext on my windows home using docker.
I have everything setup according to the tutorial on official frapper docker repo on github.
I am getting the following error and couldn’t find any solution for it anywhere.
please help me

PS C:\WINDOWS\system32\frappe_docker> docker-compose --project-name laxmierp -f installation/docker-compose-common.yml -f installation/docker-compose-erpnext.yml -f installation/docker-compose-networks.yml --project-directory installation up -d
WARNING: The MYSQL_ROOT_PASSWORD variable is not set. Defaulting to a blank string.
WARNING: The ERPNEXT_VERSION variable is not set. Defaulting to a blank string.
WARNING: The SITES variable is not set. Defaulting to a blank string.
WARNING: The LETSENCRYPT_EMAIL variable is not set. Defaulting to a blank string.
WARNING: The MARIADB_HOST variable is not set. Defaulting to a blank string.
WARNING: The FRAPPE_VERSION variable is not set. Defaulting to a blank string.
ERROR: no such image: frappe/erpnext-worker:: invalid reference format

I’ve no experience with setting up docker on windows


same issue. Did you solve it?

Not yet! Now i am trying to install the development version.
let’s see , will update you here.