ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

List of variables usable in Print Format


#1

hi, this is the first time i use the print builder and am having some issues with it ;(
i want to get the address of the company and the details in there, but what ever i try (else than the name) it says that the code is undefined or give me an error, can anyone help please :frowning:

and is there a list of what variables can be used in there?

thanks


#2

@ramielian Please share you code snippet.


#3

Search here:

http://frappe.github.io/erpnext/current/models/


#4

@rmehta hi, thanks for the link, now am wondering, if i need to get information about the company that are not listed in the form that am editing, what should i do?
exp: i need to get all company information for sales order (company address, phone, registration…etc)

@saurabh6790 i tried many things but am not really familiar with ninja, some of what i tried is:
{{doc.company.address}} {{doc.company,address}} {{doc.company;address}} {{doc.company’address’}}
{{doc.company_address}}

its all giving errors / undefined.
@rmehta @saurabh6790 and another thing please, there is no section for tax ID number for the company? i mean a dedicated one only for tax…


#5

@ramielian
you can use below code to fetch values from another doctype

{% set u = frappe.get_doc("Company", doc.company) %} 
{{ u.country or '' }} 
{{u.address or ''}} <!-- TO print company address -->

#6

i love you man @kolate_sambhaji


#7

@ramielian please do not use titles like “Print Builder , some help please?” and use specific words that describe your problem. We would like to maintain a standard for this forum.


#8

Hi, the link is broken.
Is there a new list?

I’m asking to figure out what possibilities are there :slight_smile:


#9

Hi welcome to ERPNext

Here’s the current link https://frappe.io/docs/user/en/tutorial/models

This is part of the Library tutorial, that offers a good hands-on idea of how ERPNext can be extended and customized using its meta-programming features.

cheers


#10

I followed your code i can get the current doc only but i need another record for eg: i am having record 001 and record 002 , in the print format of record 2 i need the child table of record 001 is there any to do that… but now am getting the current doc instead of record 001.


#11

Awesome thanks :slight_smile:


#12

can you show your code how you executed ?