Item selection on quotes


I hope you all are as well as possible on these days.

I wanted to ask if it is normal than in the quotes, on the items table, I can not find any product, I have to expand the form corresponding to each line, and in there, I am able to seach by item code.

But on the table this does not work, unlike on sales invoice for example, than on the items table, if I start to write item’s name automatically the line gets filled and I just have to introduce the amount.

Am I doing anything wrong?!


Many thanks and kind regards from Spain,


Not normal. Should actually work.


Thanks for your reply.

Uhm, I wonder in this case where should I start looking for an error!? On the logs I can’t see anything related to Quotations, just errors related to emails.

Thanks and kind regards,


did you do any custom scripts? changes to doctypes?

any errors in the browser console?
(try also cache refresh)

happens on one machine? try a second client?

Hello @moe01325,

Many thanks for your reply.

No custom scripts. I had done something in the past but deleted it months ago.

I think there could be any change done on the doctype, but just one field added on the form customisation.

Just warnings on the console, and no errors. I have tried 2 computers, different browsers, and 2 user accounts, and in all is the same.

The reload on ERPNext has no effect, or do you mean to delete the cache on the browser?

Thanks and kind regards from Spain,


I was actually meaning the browser cache. sometimes, but usually related to custom scripts etc, this is needed.

One idea:
Could it be that the field you see in items table is the “article name” (nombre del articulo)?
I think the search per default works on the item code. So you must add the item code field to the list view.

Hi @moe01325,

Many thanks for your last message and very sorry for my slow reply.

I did as you instructed with no effect.

Today I completed an OS upgrade and switching to Docker and the thing was still in there.

I had a look at the Form Settings and discovered that the Item code was not on subtable and it was Item’s Name instead, don’t know very well why. I changed it to Item’s Code and now finally is okay.

So, this is finally solved after many months.

Many thanks for you help and very sorry to have been so blind,


1 Like