Try ERPNext Buy Support Partners Foundation Foundation Members

Item Master Default warehouse/Expense account in Multi Company Setup

While creating multi company setup we replicated same chart of accounts, warehouse and cost center names for all the companies and system automatically adds company Abbr in front of each chart of account, warehouse and cost centers.

Now the issue is that while assigning default expense accounts, warehouse and cost centers for individual item in item master we can select only one company expense account and warehouse. The receiving and stock depletion process works perfectly fine for one company but for other companies default accounts don’t work.

Please note that in our case all the names of GL accounts, warehouse and cost centers are exactly same. Only company’s abbr are automatically added by system.

Please advise how we can have the default accounts work for all the companies

You can set default Income, Expense and other accounts in the Company master as well. If you leave default field in the Item, customer and supplier field blank, then it will fetch default accounts mentioned in the Company master.

@umair. Default only works if we have only one warehouse. In our case we have more than 10 warehouses and almost 6000 items with different expense accounts

We have already assigned expense accounts to all the items and they are working perfectly for the 1st company but for all other companies system is not picking values from default expense and warehouse fields in the item master.

Plz note that expense accounts and warehouse names are same for all companies, only abbr added by system.

Can we somehow link and replace the company abbr for default exp/warehousr whenever the company is changed in any doctype?

1 Like

I agree, there should be a setup for default income / expense / cost center / warehouse for multiple companies in Item master. Please raise a github issue for that or if the issue already exists add :+1: to it.

Thanks a lot @nabinhait. I will raise github issue

Hi @ushashmi

Yes your are right. Its not possible yet. But a quick workaround without much effort, in your case can be achived easily. Its a bit tricky. Let me explain.

At the time of sales invoice prepration, with javascript you can replace the abbrivation of expense account with logged in users company abbrivation. As you said you have same expense accounts except abbrivation.

I belive this can be quick workaround for your challange.

Thanks

How did you confirm that “default only works if we have only one warehouse”? I’m experiencing something similar but couldn’t understand why it wasn’t pulling from the default account. The implementation does have multi-warehouse, so it jives with you wrote here.