ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

Issues in Billing of Material


#1

Hello Guys
I am facing issues in manufacturing when I upgrade my ERPNext version from v8 to v10.

  1. I have some BOM’s with 100’s of RM items and 15 sub-assemblies.
  2. Each sub-assembly having 5-15 RM items.
  3. I executing Material Planning Excel File from Production Planning tool against multi-level BOM’s I have.
  4. But, the excel file executed from production planning tool showing incorrect output. Some RM items of some sub-assembly not showing in downloaded material planning excel file.
  5. And these issues happening only after when I upgraded ERPNext version from v8 to v10. This issue was not there in old version of ERPNext.
  6. But yes, when insert fresh multi-level BOM in new version of ERPNext and when I execute Material Planning Sheet from production planning tool against newly inserted BOM’s, then this issue not repeating against such newly inserted multi-level BOM’s in new version. This issues happening only against old multi-level BOMS’ which I transfer in new version.
    So my questions is, why such issues happening in new version against Old BOM’s? And please tell me anything corrective actions which I need to take care during upgrade procedure or after upgrade procedure. Is anything I missed during Upgrade process, that is why such issues coming in new version?

#2

Inline replies below.

But, the excel file executed from production planning tool showing incorrect output. Some RM items of some sub-assembly not showing in downloaded material planning excel file.

In the Production Planning Tool, did you check “Multi-level BOM”? The missing items, please ensure if they were stock items.

So my questions is, why such issues happening in new version against Old BOM’s? And please tell me anything corrective actions which I need to take care during upgrade procedure or after upgrade procedure. Is anything I missed during Upgrade process, that is why such issues coming in new version?

Any evident difference in the BOM you could hint it. The V10 has been actively used by many users and this issue was not reported by any.


#3

Thanks @umair

In the Production Planning Tool, did you check “Multi-level BOM”? The missing items, please ensure if they were stock items.
Yes…we check “Multi-Level BOM” for all items

Any evident difference in the BOM you could hint it. The V10 has been actively used by many users and this issue was not reported by any.
Unfortunately, we do not see any evident different in the BOM which will hint me…But, when I Amend old BOM in v10 then I can see correct output in Matertial Planning Excel downloaded from Production Planning Tool.


#4

Kindly provide some solution…!!!


#5

Please share some data / screenshots / GIFs, so that one can locate the issue. Perhaps the item in question is a non-stock item?


#6

This are the images for the issue raised earlier (Steps 1-6)