Issue w/ Redis during bench init step

So… I’ve tried this multiple times from scratch… I’m following the hitchhikers guide to installing on Linux (Ubuntu) and everything looks like it goes ok … until I try loading the page after installing the erpnext app and find every css and image file can’t be found … all resulting in 404’s.

So I see it’s an issue with redis during the bench init step I believe. Right at the end I see these messages show up which I think is the culprit.

frappe/dist/css/
├─ desk.bundle.QPTK7X56.css                                 542.41 Kb
├─ email.bundle.AEUPTTFL.css                                4.06 Kb
├─ login.bundle.XSQQTSD3.css                                23.20 Kb
├─ print.bundle.INKZTOJ7.css                                161.05 Kb
├─ print_format.bundle.NN5QTLOK.css                         177.21 Kb
├─ report.bundle.T7U2HV24.css                               5.45 Kb
├─ web_form.bundle.F6RGCVEQ.css                             14.65 Kb
└─ website.bundle.AMTKIJMQ.css                              397.34 Kb

frappe/dist/css-rtl/
├─ desk.bundle.OT5LM37A.css                                 542.71 Kb
├─ email.bundle.6P2S2Y53.css                                4.07 Kb
├─ login.bundle.RXFB7GLY.css                                23.20 Kb
├─ print.bundle.I4ISF2CS.css                                161.20 Kb
├─ print_format.bundle.KTX3VDVW.css                         177.32 Kb
├─ report.bundle.H3SPW2ZW.css                               5.45 Kb
├─ web_form.bundle.AJ5WIH3E.css                             14.64 Kb
└─ website.bundle.MTEXAOAB.css                              397.48 Kb

 DONE  Total Build Time: 55.016s

 WARN  Cannot connect to redis_cache to update assets_json
 WARN  Cannot connect to redis_cache to update assets_json
 WARN  Cannot connect to redis_cache to update assets_json
Done in 73.56s.
✔ Application Assets Linked


yarn run v1.22.17
$ node esbuild --production --skip_frappe --run-build-command
clean: postcss.plugin was deprecated. Migration guide:
https://evilmartians.com/chronicles/postcss-8-plugin-migration
clean: postcss.plugin was deprecated. Migration guide:
https://evilmartians.com/chronicles/postcss-8-plugin-migration
File                                                        Size

 DONE  Total Build Time: 1.725s

 WARN  Cannot connect to redis_cache to update assets_json
 WARN  Cannot connect to redis_cache to update assets_json
 WARN  Cannot connect to redis_cache to update assets_json
Done in 20.10s.
SUCCESS: Bench frappe-bench initialized

==============================================================

I know that redis is running on my machine (ubuntu 21) on a Raspberry Pi 4b:

$ sudo systemctl status redis.service
● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2022-03-09 23:50:06 UTC; 18h ago
Docs: http://redis.io/documentation,
man:redis-server(1)
Main PID: 1019753 (redis-server)
Status: “Ready to accept connections”
Tasks: 5 (limit: 4444)
Memory: 2.6M
CPU: 4min 9.338s
CGroup: /system.slice/redis-server.service
└─1019753 /usr/bin/redis-server 127.0.0.1:6379

Mar 09 23:50:06 ubuntu systemd[1]: Starting Advanced key-value store…
Mar 09 23:50:06 ubuntu systemd[1]: Started Advanced key-value store.

Any ideas?? I’m stumped…

Try running bench start in one terminal. Then run bench build in a second terminal.

I’m assuming that I do that instead of “bench init”? I’ll try and see how that fares… Thx!!

I tried that and it didn’t like it… that was after I deleted my bench directory which I now think was probably not a good idea… I’m recreating it now and when its done will do the start/build in separate terminals and see what happens.

I’ll have to get back to this later… my linux box croaked due to a bad microsd card and I’ve got to fix that first… ugg…

Definitely don’t delete your bench directory. The commands have to be issued inside the bench directory.

ok… Got it… I was able to do this just now … that seemed to have helped – I’ll now proceed on with installation… Thanks for the help!!

~/frappe-bench$ bench build
Retrieving assets...
✔ Downloaded Frappe assets from http://assets.frappeframework.com/6a458460109c2135cbada84105d7923fa1322549.tar.gz

Extracting assets...

✔ Restored frappe/dist/css-rtl/web_form.bundle.AJ5WIH3E.css
✔ Restored frappe/dist/css-rtl/desk.bundle.OT5LM37A.css
✔ Restored frappe/dist/css-rtl/email.bundle.6P2S2Y53.css
✔ Restored frappe/dist/css-rtl/website.bundle.MTEXAOAB.css
✔ Restored frappe/dist/css-rtl/login.bundle.RXFB7GLY.css
✔ Restored frappe/dist/css-rtl/print_format.bundle.KTX3VDVW.css
✔ Restored frappe/dist/css-rtl/report.bundle.H3SPW2ZW.css
✔ Restored frappe/dist/css-rtl/print.bundle.I4ISF2CS.css
✔ Restored frappe/dist/js/data_import_tools.bundle.4OLPMS6H.js
✔ Restored frappe/dist/js/bootstrap-4-web.bundle.ACJ3KVM3.js
✔ Restored frappe/dist/js/list.bundle.ISJNCCSN.js
✔ Restored frappe/dist/js/libs.bundle.HRCVFWTX.js.map
✔ Restored frappe/dist/js/form.bundle.4NCS6DVN.js
✔ Restored frappe/dist/js/frappe-web.bundle.YIKHZ6H6.js.map
✔ Restored frappe/dist/js/list.bundle.ISJNCCSN.js.map
✔ Restored frappe/dist/js/print_format_builder.bundle.WT2PKCBY.js
✔ Restored frappe/dist/js/barcode_scanner.bundle.K4AINWAD.js.map
✔ Restored frappe/dist/js/data_import_tools.bundle.4OLPMS6H.js.map
✔ Restored frappe/dist/js/libs.bundle.HRCVFWTX.js
✔ Restored frappe/dist/js/report.bundle.FDPR36TL.js
✔ Restored frappe/dist/js/controls.bundle.3PBAPOXX.js
✔ Restored frappe/dist/js/web_form.bundle.OYAR26BF.js.map
✔ Restored frappe/dist/js/controls.bundle.3PBAPOXX.js.map
✔ Restored frappe/dist/js/print_format_builder.bundle.WT2PKCBY.js.map
✔ Restored frappe/dist/js/barcode_scanner.bundle.K4AINWAD.js
✔ Restored frappe/dist/js/form.bundle.4NCS6DVN.js.map
✔ Restored frappe/dist/js/checkout.bundle.PNWSN6RI.js
✔ Restored frappe/dist/js/build_events.bundle.QZ2OBUIF.js
✔ Restored frappe/dist/js/checkout.bundle.PNWSN6RI.js.map
✔ Restored frappe/dist/js/user_profile_controller.bundle.2I7H6Y2Y.js
✔ Restored frappe/dist/js/report.bundle.FDPR36TL.js.map
✔ Restored frappe/dist/js/dialog.bundle.7PGWM7KF.js
✔ Restored frappe/dist/js/dialog.bundle.7PGWM7KF.js.map
✔ Restored frappe/dist/js/desk.bundle.ONZMI5I4.js
✔ Restored frappe/dist/js/bootstrap-4-web.bundle.ACJ3KVM3.js.map
✔ Restored frappe/dist/js/build_events.bundle.QZ2OBUIF.js.map
✔ Restored frappe/dist/js/recorder.bundle.QWTNBPXO.js.map
✔ Restored frappe/dist/js/user_profile_controller.bundle.2I7H6Y2Y.js.map
✔ Restored frappe/dist/js/recorder.bundle.QWTNBPXO.js
✔ Restored frappe/dist/js/desk.bundle.ONZMI5I4.js.map
✔ Restored frappe/dist/js/frappe-web.bundle.YIKHZ6H6.js
✔ Restored frappe/dist/js/web_form.bundle.OYAR26BF.js
✔ Restored frappe/dist/css/print.bundle.INKZTOJ7.css
✔ Restored frappe/dist/css/email.bundle.AEUPTTFL.css
✔ Restored frappe/dist/css/desk.bundle.QPTK7X56.css
✔ Restored frappe/dist/css/report.bundle.T7U2HV24.css
✔ Restored frappe/dist/css/print_format.bundle.NN5QTLOK.css
✔ Restored frappe/dist/css/web_form.bundle.F6RGCVEQ.css
✔ Restored frappe/dist/css/login.bundle.XSQQTSD3.css
✔ Restored frappe/dist/css/website.bundle.AMTKIJMQ.css

Building missing assets...

✔ Application Assets Linked


yarn run v1.22.17
$ node esbuild --production --files frappe/rtl_desk.bundle.css,frappe/rtl_email.bundle.css,frappe/rtl_login.bundle.css,frappe/rtl_prie.css,frappe/rtl_report.bundle.css,frappe/rtl_web_form.bundle.css,frappe/rtl_website.bundle.css --run-build-command
File                                                        Size

 DONE  Total Build Time: 2.642s

clean: postcss.plugin was deprecated. Migration guide:
https://evilmartians.com/chronicles/postcss-8-plugin-migration
clean: postcss.plugin was deprecated. Migration guide:
https://evilmartians.com/chronicles/postcss-8-plugin-migration
Done in 4.83s.
✔ Application Assets Linked


yarn run v1.22.17
$ node esbuild --production --skip_frappe --run-build-command
clean: postcss.plugin was deprecated. Migration guide:
https://evilmartians.com/chronicles/postcss-8-plugin-migration
clean: postcss.plugin was deprecated. Migration guide:
https://evilmartians.com/chronicles/postcss-8-plugin-migration
File                                                        Size

 DONE  Total Build Time: 2.540s

Done in 4.75s.

ok… I started over from scratch… with the same results… I’m using nginx to access the site from my desktop machine… Thoughts? I do have bench running and I did issue a “bench build” in the other terminal window which did claim to fix some missing assets but the result is the same…

If it matters… I found the missing “frappe-web.bundle.TQ6ADYLO.js” as shown below… does this look normal or ?

~$ find . -name 'frappe-web.bundle*' -print
./frappe-bench/apps/frappe/frappe/public/js/frappe-web.bundle.js
./frappe-bench/apps/frappe/frappe/public/dist/js/frappe-web.bundle.OHUSXF36.js.map
./frappe-bench/apps/frappe/frappe/public/dist/js/frappe-web.bundle.TQ6ADYLO.js
./frappe-bench/apps/frappe/frappe/public/dist/js/frappe-web.bundle.TQ6ADYLO.js.map
./frappe-bench/apps/frappe/frappe/public/dist/js/frappe-web.bundle.OHUSXF36.js

I’m currently trying the manual installation approach as I already tried the docker one and it crapped out with some obscure issue when trying to start the container… we’ll see where this goes…

I’ve never used the docker installation. Only manual installation. Was the manual installation successful?

I just did a manual install and got the same error.

It’s kind of weird that Bench 5.7.6 would not do a simple bench init properly … I mean, you can’t do “bench start” until the site is up.

Doing a ‘bench start’ and then doing the bench build from a second window worked (no Redis errors) after the bench init.

‘bench init’ is a pretty fundamental command.

No… the manual installation crapped out similarly – when I load the page when the installation is done virtually all of my css/png or other assets are missing…

I’m now back at it again and am following an ubuntu specific manual installation doc I found when trying to find the manual install docs I used a week ago or so… The only difference in the steps so far was specifying bench init again as I started over from scratch.

In this one I specified the version of frappe instead of letting it get the latest – which I think is 13? or maybe that’s erpnext… :slightly_smiling_face:

This is the command used:

bench init frappe-bench --frappe-branch version-13

When I did the “bench start” I am seeing this going on now – very slowly but methodically:

12:39:16 web.1            |  * Debugger is active!
12:39:16 web.1            |  * Debugger PIN: 646-545-387
12:39:19 watch.1          |
12:39:19 watch.1          | Rollup Watcher Started
12:39:19 watch.1          |
12:39:19 watch.1          | Watching...
12:39:22 watch.1          | Browserslist: caniuse-lite is outdated. Please run:
12:39:22 watch.1          | npx browserslist@latest --update-db
12:39:25 watch.1          | Rebuilding frappe-web-b4.css
12:39:26 watch.1          | Rebuilding frappe-recorder.min.js
12:39:36 watch.1          | Rebuilding checkout.min.js
12:39:36 watch.1          | Rebuilding frappe-web.min.js
12:39:42 watch.1          | Rebuilding bootstrap-4-web.min.js
12:39:45 watch.1          | Rebuilding control.min.js
12:40:01 watch.1          | Rebuilding dialog.min.js
12:40:07 watch.1          | Rebuilding desk.min.css
12:40:08 watch.1          | Rebuilding printview.css
12:40:09 watch.1          | Rebuilding desk.min.js
12:40:30 watch.1          | Rebuilding form.min.js
12:40:46 watch.1          | Rebuilding list.min.js
12:40:49 watch.1          | Rebuilding report.min.css
12:40:49 watch.1          | Rebuilding report.min.js
12:40:53 watch.1          | Rebuilding web_form.min.js
12:40:53 watch.1          | Rebuilding web_form.css
12:40:53 watch.1          | Rebuilding email.css
12:40:53 watch.1          | Rebuilding barcode_scanner.min.js
12:40:57 watch.1          | Rebuilding user_profile_controller.min.js
12:40:58 watch.1          | Rebuilding login.css
12:40:58 watch.1          | Rebuilding data_import_tools.min.js
12:41:03 watch.1          | Rebuilding frappe-web-b4.css
12:41:07 watch.1          | Rebuilding desk.min.css
12:41:07 watch.1          | Rebuilding printview.css
12:41:07 watch.1          | Rebuilding report.min.css
12:41:07 watch.1          | Rebuilding web_form.css
12:41:07 watch.1          | Rebuilding email.css
12:41:08 watch.1          | Rebuilding login.css

I do NOT recall seeing that rebuilding things before like this… I’ll continue and see what happens…

ok… All fixed… A permission issue with my frappe user’s home account not being accessible by anyone but root… doh! Once I issued a “chmod -R o+rx” on the home directory the frappe stuff lives in, all was good.

Thx all!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.