Issue: Bench start is not working

Hello Guys,
Good Morning!!
I am facing below issue when performed bench start command.

Satellite-Pro-C50-A:~/developer/erpnext/frappe-bench$ bench start
12:01:59 system           | redis_socketio.1 started (pid=24936)
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.486 * Increased maximum number of open files to 10032 (it was originally set to 1024).
12:01:59 redis_socketio.1 |                 _._                                                  
12:01:59 redis_socketio.1 |            _.-``__ ''-._                                             
12:01:59 redis_socketio.1 |       _.-``    `.  `_.  ''-._           Redis 3.0.6 (00000000/0) 64 bit
12:01:59 redis_socketio.1 |   .-`` .-```.  ```\/    _.,_ ''-._                                   
12:01:59 redis_socketio.1 |  (    '      ,       .-`  | `,    )     Running in standalone mode
12:01:59 redis_socketio.1 |  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 12000
12:01:59 redis_socketio.1 |  |    `-._   `._    /     _.-'    |     PID: 24942
12:01:59 redis_socketio.1 |   `-._    `-._  `-./  _.-'    _.-'                                   
12:01:59 redis_socketio.1 |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
12:01:59 redis_socketio.1 |  |    `-._`-._        _.-'_.-'    |           http://redis.io        
12:01:59 redis_socketio.1 |   `-._    `-._`-.__.-'_.-'    _.-'                                   
12:01:59 redis_socketio.1 |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
12:01:59 redis_socketio.1 |  |    `-._`-._        _.-'_.-'    |                                  
12:01:59 redis_socketio.1 |   `-._    `-._`-.__.-'_.-'    _.-'                                   
12:01:59 redis_socketio.1 |       `-._    `-.__.-'    _.-'                                       
12:01:59 redis_socketio.1 |           `-._        _.-'                                           
12:01:59 redis_socketio.1 |               `-.__.-'                                               
12:01:59 redis_socketio.1 | 
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.488 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.488 # Server started, Redis version 3.0.6
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.488 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.488 * The server is now ready to accept connections on port 12000
12:01:59 system           | web.1 started (pid=24955)
12:01:59 system           | worker_default.1 started (pid=24949)
12:01:59 system           | redis_queue.1 started (pid=24952)
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.506 * Increased maximum number of open files to 10032 (it was originally set to 1024).
12:01:59 redis_queue.1    |                 _._                                                  
12:01:59 redis_queue.1    |            _.-``__ ''-._                                             
12:01:59 redis_queue.1    |       _.-``    `.  `_.  ''-._           Redis 3.0.6 (00000000/0) 64 bit
12:01:59 redis_queue.1    |   .-`` .-```.  ```\/    _.,_ ''-._                                   
12:01:59 redis_queue.1    |  (    '      ,       .-`  | `,    )     Running in standalone mode
12:01:59 redis_queue.1    |  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 11000
12:01:59 redis_queue.1    |  |    `-._   `._    /     _.-'    |     PID: 24960
12:01:59 redis_queue.1    |   `-._    `-._  `-./  _.-'    _.-'                                   
12:01:59 redis_queue.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
12:01:59 redis_queue.1    |  |    `-._`-._        _.-'_.-'    |           http://redis.io        
12:01:59 redis_queue.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
12:01:59 redis_queue.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
12:01:59 redis_queue.1    |  |    `-._`-._        _.-'_.-'    |                                  
12:01:59 redis_queue.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
12:01:59 redis_queue.1    |       `-._    `-.__.-'    _.-'                                       
12:01:59 redis_queue.1    |           `-._        _.-'                                           
12:01:59 redis_queue.1    |               `-.__.-'                                               
12:01:59 redis_queue.1    | 
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.507 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.507 # Server started, Redis version 3.0.6
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.507 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.507 * The server is now ready to accept connections on port 11000
12:01:59 system           | watch.1 started (pid=24954)
12:01:59 system           | worker_long.1 started (pid=24939)
12:01:59 system           | redis_cache.1 started (pid=24951)
12:01:59 system           | socketio.1 started (pid=24953)
12:01:59 socketio.1       | /bin/sh: 1: /usr/local/bin/node: not found
12:01:59 system           | socketio.1 stopped (rc=127)
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.535 * Increased maximum number of open files to 10032 (it was originally set to 1024).
12:01:59 redis_cache.1    |                 _._                                                  
12:01:59 redis_cache.1    |            _.-``__ ''-._                                             
12:01:59 redis_cache.1    |       _.-``    `.  `_.  ''-._           Redis 3.0.6 (00000000/0) 64 bit
12:01:59 redis_cache.1    |   .-`` .-```.  ```\/    _.,_ ''-._                                   
12:01:59 redis_cache.1    |  (    '      ,       .-`  | `,    )     Running in standalone mode
12:01:59 redis_cache.1    |  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 13000
12:01:59 redis_cache.1    |  |    `-._   `._    /     _.-'    |     PID: 24969
12:01:59 redis_cache.1    |   `-._    `-._  `-./  _.-'    _.-'                                   
12:01:59 redis_cache.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
12:01:59 redis_cache.1    |  |    `-._`-._        _.-'_.-'    |           http://redis.io        
12:01:59 redis_cache.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
12:01:59 redis_cache.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
12:01:59 redis_cache.1    |  |    `-._`-._        _.-'_.-'    |                                  
12:01:59 redis_cache.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
12:01:59 redis_cache.1    |       `-._    `-.__.-'    _.-'                                       
12:01:59 redis_cache.1    |           `-._        _.-'                                           
12:01:59 redis_cache.1    |               `-.__.-'                                               
12:01:59 redis_cache.1    | 
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.536 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.536 # Server started, Redis version 3.0.6
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.536 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.536 * The server is now ready to accept connections on port 13000
12:01:59 system           | worker_short.1 started (pid=24963)
12:01:59 system           | schedule.1 started (pid=24948)
12:01:59 system           | sending SIGTERM to redis_socketio.1 (pid 24936)
12:01:59 system           | sending SIGTERM to worker_long.1 (pid 24939)
12:01:59 system           | sending SIGTERM to watch.1 (pid 24954)
12:01:59 system           | sending SIGTERM to redis_queue.1 (pid 24952)
12:01:59 system           | sending SIGTERM to web.1 (pid 24955)
12:01:59 system           | sending SIGTERM to schedule.1 (pid 24948)
12:01:59 system           | sending SIGTERM to worker_default.1 (pid 24949)
12:01:59 system           | sending SIGTERM to redis_cache.1 (pid 24951)
12:01:59 system           | sending SIGTERM to worker_short.1 (pid 24963)
12:01:59 redis_cache.1    | 24969:signal-handler (1525242719) Received SIGTERM scheduling shutdown...
12:01:59 system           | watch.1 stopped (rc=-15)
12:01:59 redis_queue.1    | 24960:signal-handler (1525242719) Received SIGTERM scheduling shutdown...
12:01:59 redis_socketio.1 | 24942:signal-handler (1525242719) Received SIGTERM scheduling shutdown...
12:01:59 system           | worker_default.1 stopped (rc=-15)
12:01:59 system           | worker_long.1 stopped (rc=-15)
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.564 # User requested shutdown...
12:01:59 redis_socketio.1 | 24942:M 02 May 12:01:59.564 # Redis is now ready to exit, bye bye...
12:01:59 system           | redis_socketio.1 stopped (rc=-15)
12:01:59 system           | schedule.1 stopped (rc=-15)
12:01:59 system           | worker_short.1 stopped (rc=-15)
12:01:59 system           | web.1 stopped (rc=-15)
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.607 # User requested shutdown...
12:01:59 redis_queue.1    | 24960:M 02 May 12:01:59.607 # Redis is now ready to exit, bye bye...
12:01:59 system           | redis_queue.1 stopped (rc=-15)
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.636 # User requested shutdown...
12:01:59 redis_cache.1    | 24969:M 02 May 12:01:59.636 # Redis is now ready to exit, bye bye...
12:01:59 system           | redis_cache.1 stopped (rc=-15)

Anybody has solution ?
Thanks.

What versions of frappe and erpnext are you into?

Seems issue with node.

Please check whether nodejs is located

which node or which nodejs

@ johnskywalker,
how we can check the version of frappe and erpnext?

Welcome to ERPNext

If you have console access:

frappe@ubuntu:~/frappe-bench$ bench version
erpnext 10.1.20
frappe 10.1.21

And two other ways

when i give bench version
i got the following only.

/ErpNext/frappe-bench$ bench version
frappe 10.1.30

is frappe and erpnext is different. if so, i installed frappe can anyone suggest how to install erpnext

Yes you seem to be missing erpnext, that requires frappe. You best follow the official install steps https://github.com/frappe/bench#manual-install

What I did was use the production method on linux 16.04. However apt install python-dev build-essential python-setuptools instead of the ones that are in the github setup. I found it to be (mostly) smooth sailing from there.