Is V5 on Master now?

Just wondering is V5 on Master now? When I run ‘bench update’ i get to upgrade but with errors. Haven’t successfully upgraded from V4 to V5 yet.

Please help! Any upgrade instructions to follow?

what are the errors?

/home/ubuntu/frappe-bench/env/bin/python: No module named num2words
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.1’, ‘console_scripts’, ‘bench’)()
File “/home/ubuntu/bench-repo/bench/”, line 56, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 610, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 590, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 936, in invoke
return processresult(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 782, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 416, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu/bench-repo/bench/”, line 239, in update
pre_upgrade(version_upgrade[0], version_upgrade[1])
File “/home/ubuntu/bench-repo/bench/”, line 442, in pre_upgrade
File “/home/ubuntu/bench-repo/bench/”, line 24, in remove_shopping_cart
run_frappe_cmd(’–site’, ‘all’, ‘remove-from-installed-apps’, ‘shopping_cart’, bench=bench)
File “/home/ubuntu/bench-repo/bench/”, line 434, in run_frappe_cmd
subprocess.check_call((f, ‘-m’, ‘frappe.utils.bench_helper’, ‘frappe’) + args, cwd=sites_dir)
File “/usr/lib/python2.7/”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘(’/home/ubuntu/frappe-bench/env/bin/python’, ‘-m’, ‘frappe.utils.bench_helper’, ‘frappe’, ‘–site’, ‘all’, ‘remove-from-installed-apps’, ‘shopping_cart’)’ returned non-zero exit status 1

bench update --upgrade

@rmehta I’ve done it, but received the error i pasted above…

bench update --requriements
bench retry-upgrade

@pdvyas hi, i’ve tried running but no such command.

root@ip-172-31-24-166:~# bench update --requriements
Usage: bench update [OPTIONS]

Error: no such option: --requriements

@pdvyas I get this error when i try to ‘bench retry-upgrade’

root@ip-172-31-24-166:~# bench retry-upgrade

Perhaps try “bench update --requirements”
It looks like requirements was misspelled.