ERPNext Conference 2019* ERPNext.com Blog

Is there any way to install erpnext v10 now?


#1

I’m trying to install erpnext v10.1.80 now. I’ve tried many ways but all were failed.

anyone can help me to install ERPNEXT Version 10.1.80 now?


Frappe installation version 10.x.x
#2

Hey,

See the instructions here [Release] Instructions for updating to/staying on v10/v11


#3

If you’re using the easy install script, you can add the --frappe-branch v10.x.x argument and --erpnext-branch v10.x.x argument like so:

sudo python install.py --production --user frappe --frappe-branch v10.x.x --erpnext-branch v10.x.x

Can I stay on v10 and update to the latest v10 release? (Other thread was closed without a solution)
"Easy Install" for v10 no longer works. Fails every time w/same error-multiple OS
New install of v10.x.x is Unable to Run "setup_wizard.js"
Is possible to import old database of erpnext v10 into newest erpnext version?
#4

it works with me

thanks


#5

Works well but seems to install pip 19.0.3. You might need 9.0.3 in case you have multiple custom /thirdparty apps.

cd frappe-bench
source env/bin/activate
python -m pip install pip==9.0.3

The common error is this:

Update: this causes conflicts, the best thing is to update failing app setup.py files to the newly accepted syntax. Simply compare your’s to erpnext’s setup.py


#7

I tried to add the arguments for 10 as you mentioned but it still installed 12 :frowning:
I followed this guide:

and to run the install script entered

python install.py --production --user erpnext --site mysite.com --frappe-branch v10.x.x --erpnext-branch v10.x.x

Did something change?

I have 10.x backup, no apps and am having difficulties with 12… when restoring and doing bench migrate I get errors and I have little time to figure it out T_T


#9

@Airbag888 Try this

sudo python install.py --production --user frappe --frappe-branch version-11 --erpnext-branch version-11

#10

Are you saying I don’t have to specify a ‘–site’ argument?

I typed the same as you except chose site and for frappe-branch and erpnext-branch picked v10.x.x because that’s what my backups versions are


#11

Yes this thread mirrors your problem How do I install v10 or v11 production with easy install script now that v12 is the default? [Question Revised for Clarity]


#12

@Airbag888 Difference between mine and yours is that the version tags have changed since version 12.

In your case you have
Screenshot%20from%202019-07-31%2023-08-28

While the correct command is

Screenshot%20from%202019-07-31%2023-12-23


#13

@jkimathi Thanks. I want to point out I want version 10 installed though not 11. Should I use the version-10 tag instead?


#14

Just went through your link and yeah it’s exactly the same… :frowning: No way around this? Could I do a manual install maybe? Really need v10 sorted out as my v10 backup doesn’t restore properly on v12


#15

I have not found a way to install v10 again. It appears after the launch of V12, all of the work-around procedures have been defeated again and nothing works.

In fact, it is difficult to even get a v11 install to go properly. It is a very sad state of affairs when the “supposedly” supported versions appear to be intentionally sabotaged with every new release of the next version. Not sure why the core devs are doing this, and yet their only response is that they will fix those problems ONLY if someone else in the community submits a PR to fix the stuff they broke!

It is insane.

BKM