ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Is there any way to host ERPNext from a VPS centos based?

installation
installation_problem
erpnext
install

#1

Hello community

I have a dedicated hosting environment in some VPS.
I have full/root access to the CentOs, cPanel and WHM.

Now I want to host ERPNext from the VPS, I tried to install directly on centos but there are some dependency conflict.

is there any way within cPanel or any other way to accomplish this?

please help,


How to install ERPNext in CPanel
#2

Can you share the screenshots or the error messages from yum?

Furthermore, In a very generic way,
a clean Centos or Ubuntu installation is the best starting point.
Then you download the install script and it install all packages and dependencies for you.
Everything done by bash shell.
I have no idea if exist any package for CPanel or WHM.
In my knowledge, the only preinstalled things you can find in a public cloud, are stored in AWS.
Are ami images provided by bitnami and not by ERPNext itself.
For your privare cloud you can download the ova images from ERPNext website


#3

See here Error: python-devel conflicts with python-2.7.5-68.el7.x86_64

To avoid confusion and a fragmented response this earlier duplicate thread will be closed


#4

thank u @fromthestone for replying me

when I run python install.py --production --user frappe I get this error

Error: Package: perl-Git-1.8.3.1-14.el7_5.noarch (@updates)
           Requires: git = 1.8.3.1-14.el7_5
           Removing: git-1.8.3.1-14.el7_5.x86_64 (@updates)
               git = 1.8.3.1-14.el7_5
           Updated By: git-1.8.3.1-20.el7.x86_64 (updates)
               git = 1.8.3.1-20.el7
           Available: git-1.8.3.1-19.el7.x86_64 (base)
               git = 1.8.3.1-19.el7
Error: python-devel conflicts with python-2.7.5-68.el7.x86_64
You could try using --skip-broken to work around the problem
Found 229 pre-existing rpmdb problem(s), 'yum check' output follows:
GeoIP-1.5.0-13.el7.x86_64 is a duplicate with GeoIP-1.5.0-11.el7.x86_64
1:NetworkManager-1.12.0-10.el7_6.x86_64 is a duplicate with 1:NetworkManager-1.1

The 'GitPython==2.1.11' distribution was not found and is required by bench
#5

Centos and Ubuntu use different package managers, yum versus apt-get, each with their own package database. That may explain your problem of dependent package conflicts.

Possibly one workaround is to create a distinct Python environment with tools like these:

https://github.com/pyenv/pyenv
https://medium.freecodecamp.org/manage-multiple-python-versions-and-virtual-environments-venv-pyenv-pyvenv-a29fb00c296f

BKM and others have documented ERPNext installs on CentOS check those for pointers.


#6

From what I can understand,
You probably have a repository different than EPEL and others came with default Centos installation that creating this mess…
You should do yum info package_name to check from which repo comes from.
Then, you should try to remove the conflicting packaging using rpm (with some of them might use --nodeps )
After, remove the repository, go with yum update and your problem should fix it.

It could happen that yum and rpm db need to be synchronized if you get a message like this:
Warning: RPMDB altered outside of yum.

you can use yum history sync

you can check how to use rpm here:
https://www.golinuxhub.com/2014/01/how-to-installuninstallupgrade-rpm.html

About yum commands:


#7

thank u sir for replying

I installed erpnext on a fresh centos, my problem is; alongside cpanel/whm


#8

I’m afraid to crush something in vps, trying in virtualBox first installed cpanel/whm and now when I run sudo python install.py --production --user frappe I get permission denied error, tried as root as well as non root

[bench@cpanel frappe-bench]$ sudo python install.py --production --user frappe
Loaded plugins: fastestmirror, langpacks, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 185.69.232.245
 * cpanel-addons-production-feed: 185.69.232.245
 * cpanel-plugins: 185.69.232.245
 * base: mirror.dc.uz
 * epel: mirror.hoster.kz
 * extras: mirror.dc.uz
 * remi: mirror.hoster.kz
 * remi-safe: mirror.hoster.kz
 * updates: mirror.dc.uz
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Loaded plugins: fastestmirror, langpacks, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 185.69.232.245
 * cpanel-addons-production-feed: 185.69.232.245
 * cpanel-plugins: 185.69.232.245
 * base: mirror.dc.uz
 * epel: mirror.hoster.kz
 * extras: mirror.dc.uz
 * remi: mirror.neolabs.kz
 * remi-safe: mirror.neolabs.kz
 * updates: mirror.dc.uz
Package epel-release-7-11.noarch already installed and latest version
Package redhat-lsb-core-4.1-27.el7.centos.1.x86_64 already installed and latest version
.
.
.
Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in /usr/lib64/python2.7/site-packages (from jinja2->ansible) (1.1.1)
Traceback (most recent call last):
  File "install.py", line 432, in <module>
    install_bench(args)
  File "install.py", line 106, in install_bench
    run_playbook('create_user.yml', extra_vars=extra_vars)
  File "install.py", line 344, in run_playbook
    success = subprocess.check_call(args, cwd=os.path.join(cwd, 'playbooks'))
  File "/usr/lib64/python2.7/subprocess.py", line 537, in check_call
    retcode = call(*popenargs, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 524, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied

any help please


#9

I never user CPanel neither WHM,
but about what I remember, these packages modify the system a lot, in order to jail it as much as possible in terms of security and multiuser use.
I am quite sure that the issue is belong those package.
Did you try an installation without any CPanel/WHM?
I really suggest to use this VM host only for the ERP, and no anything else software that can modify the configuration of the system.
If you really cannot live without any graphic control panel, try to use Webmin + Virtualmin…
Another suggestion that I give you, is to open a compatibility issue on ERPNext GitHub page.


#10

Yes I installed erpnext without cpanel/whm with no error.