Is filter mandatory to show list in customers?

In my customer list by default it shows nothing. Pl see screenshot below. Only if I filter the customer group and territory it shows. The list is indeed well populated, but how can I make sure when not filtered to show the full list?


You can remove the default customer group and default territory from selling settings. Then the customer list will be displayed without any filter.

Thank you Saumyaseelan. I just did that, but still no change. Pl see screenshot below.