Is Easy Install Script being phased out?

I know you think this is always a good excuse Rushabh but it really isn’t (at least, not always). In the years we’ve been around, we’ve contributed a fair bit to ERPNext whether you’re aware or not. We’ve advertised in our region, introduced a decent number of people to the product, and encouraged them to host with Frappe without prompting from you and without incentives. We also tried contributing code but quickly found it to be quite an uphill task (and I understand the reasons you’ve given for this) which is probably why you always complain that you’re not getting enough contributions from the community

From the way things are currently structured and being driven, the Frappe Team is likely to continue being the major contributor (and beneficiary) of the project for the foreseeable future and many of us are fine with that. Your leadership has brought the product to where it is today and that is highly commendable. What I don’t think you should be doing is addressing people in a condescending manner just because they pointed out issues with communication gaps that leave users stranded or because you feel they’re not contributing enough

At the end of the day, when users have a better experience with the product, adoption increases and everyone (especially the Frappe Team) benefits. And whenever you try to showcase ERPNext as a product with a large “community” behind it, remember that’s us you’re referring to (regardless of our varying levels of contribution)

Oh, and by the way, It’s not a rant Rushabh… just stating the obvious



lt me honestly put how it sounds to my ears: BS

Reason for that is probably people tend to focus on problems that will earn them more interest and modey. The Easy Install script breaks whenever there is any inconsistency and even the packages themselves return warning, error messages or break the process. I have even myself have found out the way to hack into the process to install ERPNext on a 2GB Ram virtual server. Just, we are too lazy to have responsibility to report and go through the process of updating the code. The responsibility is on both sides but having a hard installation process will be another burden for such a great and promising project.
I will personally do as much as I can to maintain the code from now on.

Of course my dear. We will do more.
After we lost @clarkej , we have lost some of the momentum I feel. Even though I did not like him when he was alive, I strongly feel his absence. May he rest in light and power.


I was very careful to double-check with Gavin. I specifically asked if this was a change (i.e. deprecated). He said yes.

Easy Install is physically part of the official repositories. Why would a reasonable person expect that ‘some’ Python files in a GitHub repository behave differently than other Python files?

The point is not that the community cannot (or should not) step up and fix things. I agree with you there.

The point is this:

  • Deleting features (or abandoning them) after they’ve been around 10-ish years.
  • …that you know, for a fact, are being widely used…
  • …without taking the time to make a quick announcement or “heads up”

…is going to upset people.

On the other hand. Had one of the Maintainers made a quick post like this:

Hey, the maintainers simply don’t have time to maintain ‘Easy Install’ anymore. If anyone in the community can step up, and lend a hand, this feature can stick around. Otherwise probably not. Any volunteers?!

Then this change would have gone very differently. And we wouldn’t be having this online conversation.


Hi @peterg,
Thanks for VPS example,
I am trying to install ERPNext on VPS,
Is it possible can you please your VPS CPU , RAM and Disk storage ,
It will help to experiment erpnext on vps with minimum resources .
Ex: can we install in 1 GB ram and 1 core CPU like that ?

If you set up swap space, it will work with as little as 1GB memory, but results tend to be mixed. For small deployments I’ve always tended to use 2gb and 2 vCPU. I’m not sure how docker Impacts resource use, though.

My point… not everyone will be hard-core techies who will know GIT or Core-Dev Stuff… A lot of us are seasoned IT Professionals with experience around Consulting, Implementation, Analytics and various other areas of IT, and may not know the nitty gritties of GIT, Ansible, Dockers etc… We want to implement ERPNext for its awesomeness as a Business Solution (not only for the freesomeness or technical prowess).

So we do have Customers who are OK to pay for ERPNext’s support, but for data compliance reasons, they cannot host it on the cloud… In such cases, it would be good to have an easy-to-use GUI Installer of some kind, that would let an IT-Pro to install the software (should not require a hard-core developer to install).

For a team that has built such an amazing software as ERPNext, I am sure someone from the Core-Dev Team could take this up and write a nice little Installer (GUI or Command-Line), which would make the whole installation process seamless…

Food for thought !!


Thanks @peterg

Could you please write a post about your installation process.
it will be helpful for docker beginers

As I said before, my process was literally exactly the installation instructions listed on github. The only variation was running the “create site” command twice instead of once.

I’m sure Revant would be extremely happy for us to help improve those docs, but please at least give the existing instructions a shot before asking for help.

I tried every possible installation of the Erpnext.
most of the time it ends up with errors,

  1. Started with the official v12 OVA it works fine. :+1:

  2. Then tried to upgrade that OVA to v13 in Virtualbox couldn’t get succed.

  3. After using the trial version of v13 on I thought to get to know more about the process. So before going to actually use the ERP in my business. I wanted to further dig into version upgrade, backup and restore functionality.

  4. Therefore I tried to manually install v13 on ubuntu server 20.04 in Virtualbox. The installation ran smoothly but finally v13 loaded to the browser without styling and js. so tried building assets again couldn’t get it to succuss. it leads to more and more errors.

  5. Found a v13 OVA which was created by a community member and started using it. It works fine, then I tried to restore the database which I have configured in the trial. it fails with a lot of errors.

  6. Finally I learned docker fundamentals and started with single-bench docker installation.
    Right now

source .env

command displays an error

wbs.localhost: command not found

my .env file as follows

appreciate any help.

Ubuntu Server 20.04 in Oracle VirtualBox
Client: Docker Engine - Community
Version: 20.10.8
API version: 1.41
Go version: go1.16.6
Git commit: 3967b7d
Built: Fri Jul 30 19:54:27 2021
OS/Arch: linux/amd64
Context: default
Experimental: true

Server: Docker Engine - Community
Version: 20.10.8
API version: 1.41 (minimum version 1.12)
Go version: go1.16.6
Git commit: 75249d8
Built: Fri Jul 30 19:52:33 2021
OS/Arch: linux/amd64
Experimental: false
Version: 1.4.9
GitCommit: e25210fe30a0a703442421b0f60afac609f950a3
Version: 1.0.1
GitCommit: v1.0.1-0-g4144b63
Version: 0.19.0
GitCommit: de40ad0

In this case, the first thing to do is to see where you’re getting an error. wbs.localhost appears twice in your .env file, after SITE_NAME and after SITES. Look at the documentation here:

It says that the SITES value should be quoted in backticks. The env-production included with the repo also has a default value quoted in backticks. In your case, however, there are no backticks. That’s the source of the error.

no need to use source command. it will try to execute whatever is quoted with back ticks.

docker-compose up should pick up the .env file anyway

There are. I tried to edit the post and I can see them there. They’re lost in markdown formatting.


Ok then, I skipped source .env command and completed the steps.
logs for docker logs wbs_site-creator_1 -f as follows

Attempt 1 to connect to mariadb:3306
Attempt 1 to connect to redis-queue:6379
Attempt 1 to connect to redis-cache:6379
Attempt 1 to connect to redis-socketio:6379
Connections OK
Site wbs.localhost already exists

Now docker ps shows all 12 containers are up and running.

But still, I can’t figure out How can I access the system from the Host.
What I have tried already is

  1. Added port forwarding to VM

  2. Tried to access the site using the Host browser


non of the above URL is working browser shows

This site can’t be reached
wbs.localhost refused to connect or The connection was reset.

I already tried clearing browser cache and with different browsers…
and also temporarily disabled the Host & Guest os firewall following

sudo ufw disable

Still, I can’t access the site from the Host os browser
Is there anything I didn’t understand or did wrongly?
@revant_one and @peterg

This happens when site-creator container runs second time. It is there to guard from overwriting the same site again.

  1. you can delete the site directory from volumes, also make sure there is no mariadb database created for the site.
  2. you can use different site name. It’ll create another site with the given name.
  3. you can use the --force options or set environment variable FORCE=1.

Create a separate post for this, It will also help others who search the forum later.

Well, as one of the latest members (at least I think I’m the newest) with very limited IT knowledge (I know a little python and must usually search everything when reading your discussions) I must say:
I had problems with the official easy install and followed the @bkm Guide which worked like a charm.(Thanks)
After that I learned some bench commands (update and migrate really), didn’t work on ssl so I got certbot which did the job.
Learned some basic UFW, and Fail2Ban and authkey+googleauth for the server, and ready to go.
and well I won’t be touching the server as long as I can because I’m afraid I might break something :D.
As for using the system, most things are well explained in Docs and videos, the confusing parts are usually in the 1-changes for example chat is disabled, but in docs chat is there, and on website it’s there but internally its not present took me some searching. or sometimes things are added but docs have not caught up yet. 2- things not directly explained for example I still don’t know where does the email address from contact-us page go, A contact is created and in email inbox the message is shown but the contact isn’t , the email forwarded to my gmail also doesn’t show it. if you hit reply in the inbox you can see it. also it was very hard to find the inbox.
As for docker, I’m just learning what containers are.
I explained these things so that it might help you see things from the perspective of a new member.
But in general I had no problems, and am very very thankful. I have accounting, inventory, sales, a website,… and all of them connected and online.
So about this platform being against new members … I must disagree, I’m glad I’m here, and hope I can contribute in the future.

1 Like

Sorry for the delay in updating here, but the PR
to make version-13 default for easy install script was merged on 30th Aug.