Internal server error (production version)

when i run the erp on my VM everything seems fine but when i finish the setup i get this error (internal server error)

here some pics

help please

1 Like

Internal server error usually means your mariadb database service is not running

1 Like

hi @Joseph_Marie_Alba and thanks for your response.
i checked and mariadb is installed

how to make sure its running ?? is there a command to do that ??

cheers

sudo systemctl start mysql or sudo service mysql start

you should also run a sudo systemctl service mysql enable afterwards. This should make the mariadbserver (the mysql service) start automatically when your machine boots up.

1 Like

hello @vrms i tried what you have said and the same error appears.

is there any tutorials, training, or videos on how to setup the erpnext and the mariadb ??
i am new to this so if you know any please recommend.
cheers
@vrms @Joseph_Marie_Alba

I’d copy the output (in the terminal, not what you see as a result in your browser) of systemctl mysql start and post if here and search for that error message (or part of it) in places like https://stackexchange.com or the -search engine of your preference. to find hints for addressing the issue.

also please tell us briefly how your environment looks like (which OS, how did you install erpnext, etc)

1 Like

@Abdulkader_Sandouka

Try to increase the connection timeout in my.cnf file

Might help you…!!!

1 Like

can you advise which value would be a good value for the timeout?

1 Like

@Onkar_Mirajkar @vrms @Joseph_Marie_Alba

i downloaded the erp from erpnext foundation website (production version) and i import it to VM.
i entered the frappe username and password and i started the software and everything seems OK until the final step of the setup it give me the error shown above
this is what appears in the terminal when the setup fail

and as you will see in the next pictures i tried to start mariadb but that didn’t work

and this is my logs
00:00:02.458675 ******************* End of VT-x features ********************

00:00:02.458725 PcBios: ATA LUN#0 LCHS=1024/255/63

00:00:02.458768 APIC: fPostedIntrsEnabled=false fVirtApicRegsEnabled=false fSupportsTscDeadline=false

00:00:02.458776 TMR3UtcNow: nsNow=1 575 961 670 285 798 300 nsPrev=0 -> cNsDelta=1 575 961 670 285 798 300 (offLag=0 offVirtualSync=0 offVirtualSyncGivenUp=0, NowAgain=1 575 961 670 285 798 300)

00:00:02.458797 VMEmt: Halt method global1 (5)

00:00:02.458816 VMEmt: HaltedGlobal1 config: cNsSpinBlockThresholdCfg=50000

00:00:02.458821 Changing the VM state from ‘CREATING’ to ‘CREATED’

00:00:02.459491 Changing the VM state from ‘CREATED’ to ‘POWERING_ON’

00:00:02.459916 Changing the VM state from ‘POWERING_ON’ to ‘RUNNING’

00:00:02.459929 Console: Machine state changed to ‘Running’

00:00:02.463561 VMMDev: Guest Log: BIOS: VirtualBox 6.0.14

00:00:02.463642 PCI: Setting up resources and interrupts

00:00:02.463941 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)

00:00:02.473610 ERROR [COM]: aRC=VBOX_E_VM_ERROR (0x80bb0003) aIID={ab4164db-c13e-4dab-842d-61ee3f0c1e87} aComponent={DisplayWrap} aText={Could not take a screenshot (VERR_NOT_SUPPORTED)}, preserve=false aResultDetail=-37

00:00:02.476869 VMMDev: Guest Log: CPUID EDX: 0x178bfbff

00:00:02.476913 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=0 CmdIf0=0x00 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)

00:00:02.476957 PIIX3 ATA: Ctl#0: finished processing RESET

00:00:02.477397 VMMDev: Guest Log: BIOS: ata0-0: PCHS=16383/16/63 LCHS=1024/255/63

00:00:02.477773 PIIX3 ATA: Ctl#0: RESET, DevSel=1 AIOIf=0 CmdIf0=0xec (-1 usec ago) CmdIf1=0x00 (-1 usec ago)

00:00:02.477816 PIIX3 ATA: Ctl#0: finished processing RESET

00:00:02.480672 PIT: mode=2 count=0x48d3 (18643) - 64.00 Hz (ch=0)

00:00:02.487050 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=000000000b3a0000 w=640 h=480 bpp=32 cbLine=0xA00 flags=0x0 origin=0,0

00:00:02.961204 GUI: UIMachineViewNormal::resendSizeHint: Restoring guest size-hint for screen 0 to 800x600

00:00:02.961299 VMMDev: SetVideoModeHint: Got a video mode hint (800x600x32)@(0x0),(1;0) at 0

00:00:02.966956 GUI: 2D video acceleration is disabled

00:00:02.966968 GUI: HID LEDs sync is enabled

00:00:02.972251 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5

00:00:04.962842 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)

00:00:04.963562 VMMDev: Guest Log: BIOS: Boot : bseqnr=1, bootseq=0032

00:00:04.965757 VMMDev: Guest Log: BIOS: Booting from Hard Disk…

00:00:04.966321 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=0 CmdIf0=0xc4 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)

00:00:04.966380 PIIX3 ATA: Ctl#0: finished processing RESET

00:00:04.970403 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0 flags=0x0 origin=0,0

00:00:05.163626 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=000000000b3a0000 w=640 h=480 bpp=32 cbLine=0xA00 flags=0x0 origin=0,0

00:00:05.509292 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0 flags=0x0 origin=0,0

00:00:05.705614 GIM: KVM: VCPU 0: Enabled system-time struct. at 0x000000003ffe3000 - u32TscScale=0xc587e63a i8TscShift=-1 uVersion=2 fFlags=0x1 uTsc=0x1f56a4e91 uVirtNanoTS=0xc172af41

00:00:05.705638 TM: Switching TSC mode from ‘Dynamic’ to ‘RealTscOffset’

00:00:05.719222 GIM: KVM: Enabled wall-clock struct. at 0x000000000210d2e8 - u32Sec=1575961673 u32Nano=546642088 uVersion=2

00:00:05.736271 PIT: mode=2 count=0x12a5 (4773) - 249.98 Hz (ch=0)

00:00:05.823740 APIC0: Switched mode to x2APIC

00:00:05.928034 PIT: mode=0 count=0x10000 (65536) - 18.20 Hz (ch=0)

00:00:06.427038 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=0 CmdIf0=0xc4 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)

00:00:06.427127 PIIX3 ATA: Ctl#0: finished processing RESET

00:00:06.428526 PIIX3 ATA: Ctl#1: RESET, DevSel=0 AIOIf=0 CmdIf0=0x00 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)

00:00:06.428612 PIIX3 ATA: Ctl#1: finished processing RESET

00:00:09.070034 NAT: Link up

00:00:09.322409 VMMDev: Guest Additions information report: Version 5.0.18 r106667 ‘5.0.18_Ubuntu’

00:00:09.322458 VMMDev: Guest Additions information report: Interface = 0x00010004 osType = 0x00053100 (Linux >= 2.6, 64-bit)

00:00:09.322589 VMMDev: Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no

00:00:09.322685 VMMDev: Guest reported fixed hypervisor window at 00001000000 LB 0x800000 (rc=VINF_SUCCESS)

00:00:09.322699 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners

00:00:09.322729 VMMDev: vmmDevReqHandler_HeartbeatConfigure: No change (fHeartbeatActive=false)

00:00:09.322780 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5

00:00:09.322815 VMMDev: Heartbeat flatline timer set to trigger after 4 000 000 000 ns

00:00:09.322852 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners

00:00:09.322862 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5

00:00:09.322921 VMMDev: Guest Log: vgdrvHeartbeatInit: Setting up heartbeat to trigger every 2000 milliseconds

00:00:09.329385 GUI: UISession::sltAdditionsChange: GA state really changed, notifying listeners

00:00:09.329413 GUI: UIMachineViewNormal::adjustGuestScreenSize: Adjust guest-screen size if necessary

00:00:09.329419 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners

00:00:09.329423 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5

00:00:09.329871 VMMDev: Guest Log: vboxguest: misc device minor 55, IRQ 20, I/O port d020, MMIO at 00000000f0400000 (size 0x400000)

00:00:09.699630 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=000000000b3a0000 w=800 h=600 bpp=32 cbLine=0xC80 flags=0x1 origin=0,0

00:00:09.907722 NAT: IPv6 not supported

00:00:09.911405 NAT: DHCP offered IP address 10.0.2.15

00:19:18.573691 NAT: Old socket recv size: 64KB

00:19:18.573791 NAT: Old socket send size: 64KB

note(i tried the development version and it worked fine but the production version didn’t).

cheers and thanks in advance

what is the command to increase the connection timeout ??
@Joseph_Marie_Alba @Onkar_Mirajkar @vrms

i found it her

2 Likes