Internal Server Error: After upgrade to ERPNEXT 8.0

@Amarjeet_Singh_Sintu also check your ErpNext and Frappe apps Github branch.

see below reference.

frappe-bench/apps/erpnext$ git branch
frappe-bench/apps/frappe$ git branch

They are all *master

Is the bench migrate command run successfully without errors

Yes it did without errors as I did not see any dialog box showing error @MaysaaSafadi

If your site is new and with no data try >>bench reinstall
then migrate it

1 Go to bench-repo folder
2 git pull or git pull origin
3 Go back to frappe-bench folder
4 Run bench update
5 bench use “Your site name”
6 bench migrate
7 bench clear-cache
8 bench start.

no 2 ( how , can you type the line command )

Hello @Ahmed_Khalifa,

If you want to get latest bench-repo code then
Go to bench-repo directory and then execute git pull command.

bench-repo$ git pull

1 Like

working now thanks mr. yogendrasinh

when make backup from database, and make restore , what the database sql_file_path name ?

bench backup
then
bench --site erpnext.vm restore ( sql_file_path )

Hello @Ahmed_Khalifa

Below is the command to restore database:

bench --site site_name --force restore /path/to/copied/latest_date_time_sql_backup.gz

If still have any doubts go through below link:

1 Like

Still not working. It says updating… @yogendrasinh

Hello @Amarjeet_Singh_Sintu,

Can You please provide us any screen shot or full traceback.

what is traceback? please tell me I am new and I don’t know @Chandresh_Thakkar @MaysaaSafadi @yogendrasinh @srajelli @Ahmed_Khalifa

Hello @Amarjeet_Singh_Sintu

I think it’s your cache or browser history problem.
Remove your browser history and cache.

Are you in production mode or development mode?

see below link for that:

Traceback means the report about the processes which are executed during the specific operation.

And if the execution flow breaks somewhere then the reason is given in that traceback.

How do I get the traceback (report)? @Chandresh_Thakkar @MaysaaSafadi @yogendrasinh @srajelli @Ahmed_Khalifa

In production mode… @yogendrasinh

This should help for the
traceback logs:

in Production mode…

Traceback
when i type frappe@erpnext:~/frappe-bench$ find . -name socketio.log NOTHING COMES UP
frappe@erpnext:~/frappe-bench$ find ./logs/node-socketio.error.log NOTHING COMES UP

BUT WHEN I TYPE
frappe@erpnext:~/frappe-bench$ ./logs/node-socketio.error.log IT SAYS " PERMISSION DENIED"

Please help URGENT @clarkej @krnkris