ERPNext Conference 2019* ERPNext.com Blog

Installing Frappe Error - E: Unable to locate package libssl1.0-dev


#1

Good Day Everyone,

I tried installing Frappe so as to install ERPNext but i am getting teh error below;
E: Unable to locate package libssl1.0-dev
E: Couldn’t find any package by glob ‘libssl1.0-dev’
E: Couldn’t find any package by regex ‘libssl1.0-dev’
Traceback (most recent call last):
File “install.py”, line 413, in
install_bench(args)
File “install.py”, line 21, in install_bench
‘sudo yum install -y epel-release redhat-lsb-core git python-setuptools python-devel openssl-devel libffi-devel’
File “install.py”, line 226, in run_os_command
returncode = subprocess.check_call(command, shell=True)
File “/usr/lib/python2.7/subprocess.py”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo apt-get install -y git build-essential python3-setuptools python3-dev libffi-dev libssl1.0-dev’ returned non-zero exit status 100

Any help please

Regards


#2

Try my install routine: ERPNext DNS-Multitenant - disable recursion on the DNS Server


#3

good Day Curt.Beck and unfortunately i was getting the same error message


#4

A search on this for pointers should work here!


#5

Run the following command manually, then retry the installation.

sudo apt-get install -y git build-essential python3-setuptools python3-dev libffi-dev libssl1.0-dev


#6

you can try it


#7

Thank You. I will try this right away


#8

I have created a pull request 2 weeks ago. https://github.com/frappe/bench/pull/843

libssl1.0-dev does not exists on ubuntu packages and should be replaced with libssl-dev