Installation problems

Hello,

I am having a ton of problems installing erpnext. I cannot get it installed on debian or centos. I followed the instructions on github.
Is there anyone who can help me.


Thanks



You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/6211a3de-eb96-4de1-9b37-cad9258b6162%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

Which step are you stuck at? What is the message you are getting?


W: https://erpnext.com
T: @rushabh_mehta

On 29-May-2013, at 2:41 PM, Amy Cancryn <su...@firebrandpublishing.com> wrote:

Hello,
I am having a ton of problems installing erpnext. I cannot get it installed on debian or centos. I followed the instructions on github.
Is there anyone who can help me.


Thanks




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To post to this group, send email to er…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/6211a3de-eb96-4de1-9b37-cad9258b6162%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/2C82990D-0785-40E3-BF34-15AFDD1F0F93%40erpnext.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

On centos,

the site does not go to :8080
I get the apache welcome page.

I think I have an issue setting up the virtual hosts in apache.

Can I use the nginx webserver instead of apache?

On Debian, I the prerequisites don’t install properly and when I run the install file .py It throws a ton of errors. I will retry.

Thanks

On Wednesday, May 29, 2013 5:16:30 AM UTC-4, rushabh wrote:
Which step are you stuck at? What is the message you are getting?


W: https://erpnext.com
T: @rushabh_mehta

On 29-May-2013, at 2:41 PM, Amy Cancryn <su...@firebrandpublishing.com> wrote:

Hello,
I am having a ton of problems installing erpnext. I cannot get it installed on debian or centos. I followed the instructions on github.
Is there anyone who can help me.


Thanks




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To post to this group, send email to erpnext-dev…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/6211a3de-eb96-4de1-9b37-cad9258b6162%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/0ac80f42-5a72-49da-bacc-8eb2cd63ddcb%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

This is the error I get on debian

fatal: destination path 'lib' already exists and is not an empty directory.
fatal: destination path 'app' already exists and is not an empty directory.
Traceback (most recent call last):
  File "install_erpnext.py", line 170, in <module>
    install()
  File "install_erpnext.py", line 13, in install
    setup_folders(install_path)
  File "install_erpnext.py", line 32, in setup_folders
    os.mkdir(public)
OSError: [Errno 17] File exists:

On Wednesday, May 29, 2013 5:11:04 AM UTC-4, Amy Cancryn wrote:
Hello,
I am having a ton of problems installing erpnext. I cannot get it installed on debian or centos. I followed the instructions on github.
Is there anyone who can help me.


Thanks



You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/0ae8b357-c891-42b0-82eb-d42f11c7f721%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

Amy,

On centos,
the site does not go to :8080

Can you paste the apache settings page on gist.github.com / pastebin.

When you restart apache, do you get an error?

I get the apache welcome page.

I think I have an issue setting up the virtual hosts in apache.

Can I use the nginx webserver instead of apache?

We have not tried yet but I am sure there might be a way.


On Debian, I the prerequisites don't install properly and when I run the install file .py It throws a ton of errors. I will retry.

Thanks

On Wednesday, May 29, 2013 5:16:30 AM UTC-4, rushabh wrote:
Which step are you stuck at? What is the message you are getting?


W: https://erpnext.com
T: @rushabh_mehta

On 29-May-2013, at 2:41 PM, Amy Cancryn <su...@firebrandpublishing.com> wrote:

Hello,
I am having a ton of problems installing erpnext. I cannot get it installed on debian or centos. I followed the instructions on github.
Is there anyone who can help me.


Thanks




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To post to this group, send email to erpnext-dev…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/6211a3de-eb96-4de1-9b37-cad9258b6162%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 





You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To post to this group, send email to er…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/0ac80f42-5a72-49da-bacc-8eb2cd63ddcb%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/468BFE73-3053-49DF-8EEE-3A1547D89238%40erpnext.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

You are trying to run the script a second time. Delete all the folders or run the script in an new folders.

On 30-May-2013, at 10:15 AM, Amy Cancryn <su...@firebrandpublishing.com> wrote:

This is the error I get on debian

fatal: destination path 'lib' already exists and is not an empty directory.
fatal: destination path 'app' already exists and is not an empty directory.
Traceback (most recent call last):
  File "install_erpnext.py", line 170, in <module>
    install()
  File "install_erpnext.py", line 13, in install
    setup_folders(install_path)
  File "install_erpnext.py", line 32, in setup_folders
    os.mkdir(public)
OSError: [Errno 17] File exists:

On Wednesday, May 29, 2013 5:11:04 AM UTC-4, Amy Cancryn wrote:
Hello,
I am having a ton of problems installing erpnext. I cannot get it installed on debian or centos. I followed the instructions on github.
Is there anyone who can help me.


Thanks




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To post to this group, send email to er…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/0ae8b357-c891-42b0-82eb-d42f11c7f721%40googlegroups.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.

 

 




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/EC3E38C3-0EC0-4918-B5F3-F84769378877%40erpnext.com?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.