Installation problem on Centos

hello , I am trying to install erp. but I am getting error please help me .

Send complete logs.

sudo yum -y install build-essential git ntp vim screen htop libxslt1.1 libxslt1-dev libssl-dev libcrypto+±dev postfix fontconfig libxrender1 libxext6 xfonts-75dpi xfonts-base cron curl supervisor
Loaded plugins: fastestmirror, langpacks
yumclient | 2.9 kB 00:00
Loading mirror speeds from cached hostfile
No package build-essential available.
Package 2:vim-enhanced-7.4.160-2.el7.x86_64 already installed and latest version
No package htop available.
No package libxslt1.1 available.
No package libxslt1-dev available.
No package libssl-dev available.
No package libcrypto+±dev available.
Package 2:postfix-2.10.1-6.el7.x86_64 already installed and latest version
Package fontconfig-2.10.95-11.el7.x86_64 already installed and latest version
No package libxrender1 available.
No package libxext6 available.
No package xfonts-75dpi available.
No package xfonts-base available.
No package cron available.
Package curl-7.29.0-42.el7.x86_64 already installed and latest version
No package supervisor available.
Resolving Dependencies
–> Running transaction check
—> Package git.x86_64 0:1.8.3.1-11.el7 will be installed
–> Processing Dependency: perl-Git = 1.8.3.1-11.el7 for package: git-1.8.3.1-11.el7.x86_64
–> Processing Dependency: perl(Term::ReadKey) for package: git-1.8.3.1-11.el7.x86_64
–> Processing Dependency: perl(Git) for package: git-1.8.3.1-11.el7.x86_64
–> Processing Dependency: perl(Error) for package: git-1.8.3.1-11.el7.x86_64
—> Package ntp.x86_64 0:4.2.6p5-25.el7.centos.2 will be installed
–> Processing Dependency: libopts.so.25()(64bit) for package: ntp-4.2.6p5-25.el7.centos.2.x86_64
—> Package screen.x86_64 0:4.1.0-0.23.20120314git3c2946.el7_2 will be installed
–> Running transaction check
—> Package autogen-libopts.x86_64 0:5.18-5.el7 will be installed
—> Package perl-Error.noarch 1:0.17020-2.el7 will be installed
—> Package perl-Git.noarch 0:1.8.3.1-11.el7 will be installed
—> Package perl-TermReadKey.x86_64 0:2.30-20.el7 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size

Installing:
git x86_64 1.8.3.1-11.el7 yumclient 4.4 M
ntp x86_64 4.2.6p5-25.el7.centos.2 yumclient 547 k
screen x86_64 4.1.0-0.23.20120314git3c2946.el7_2 yumclient 552 k
Installing for dependencies:
autogen-libopts x86_64 5.18-5.el7 yumclient 66 k
perl-Error noarch 1:0.17020-2.el7 yumclient 32 k
perl-Git noarch 1.8.3.1-11.el7 yumclient 53 k
perl-TermReadKey x86_64 2.30-20.el7 yumclient 31 k

Transaction Summary

Install 3 Packages (+4 Dependent packages)

Total download size: 5.6 M
Installed size: 25 M
Downloading packages:

Total 13 MB/s | 5.6 MB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : 1:perl-Error-0.17020-2.el7.noarch 1/7
Installing : autogen-libopts-5.18-5.el7.x86_64 2/7
Installing : perl-TermReadKey-2.30-20.el7.x86_64 3/7
Installing : perl-Git-1.8.3.1-11.el7.noarch 4/7
Installing : git-1.8.3.1-11.el7.x86_64 5/7
Installing : ntp-4.2.6p5-25.el7.centos.2.x86_64 6/7
Installing : screen-4.1.0-0.23.20120314git3c2946.el7_2.x86_64 7/7
Verifying : perl-TermReadKey-2.30-20.el7.x86_64 1/7
Verifying : git-1.8.3.1-11.el7.x86_64 2/7
Verifying : 1:perl-Error-0.17020-2.el7.noarch 3/7
Verifying : autogen-libopts-5.18-5.el7.x86_64 4/7
Verifying : perl-Git-1.8.3.1-11.el7.noarch 5/7
Verifying : ntp-4.2.6p5-25.el7.centos.2.x86_64 6/7
Verifying : screen-4.1.0-0.23.20120314git3c2946.el7_2.x86_64 7/7

Installed:
git.x86_64 0:1.8.3.1-11.el7
ntp.x86_64 0:4.2.6p5-25.el7.centos.2
screen.x86_64 0:4.1.0-0.23.20120314git3c2946.el7_2

Dependency Installed:
autogen-libopts.x86_64 0:5.18-5.el7 perl-Error.noarch 1:0.17020-2.el7
perl-Git.noarch 0:1.8.3.1-11.el7 perl-TermReadKey.x86_64 0:2.30-20.el7

Complete!
[root@localhost ~]# curl -sL https://deb.nodesource.com/setup_7.x | sudo bash -

Installing the NodeSource Node.js v7.x repo…

Populating apt-get cache…

100%[======================================>] 13,019 --.-K/s in 0.01s

2018-04-23 06:51:28 (1013 KB/s) - ‘install.py’ saved [13019/13019]

[root@localhost ~]# python install.py --develop --user frappe
Loaded plugins: fastestmirror, langpacks
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
yumclient | 2.9 kB 00:00
Loading mirror speeds from cached hostfile
Warning: group Development tools does not exist.
Maybe run: yum groups mark install (see man yum)
Error: No packages in any requested group available to install or update
Traceback (most recent call last):
File “install.py”, line 417, in
install_bench(args)
File “install.py”, line 21, in install_bench
‘sudo yum install -y epel-release redhat-lsb-core git python-setuptools python-devel openssl-devel libffi-devel’
File “install.py”, line 234, in run_os_command
returncode = subprocess.check_call(command, shell=True)
File “/usr/lib64/python2.7/subprocess.py”, line 542, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo yum groupinstall -y “Development tools”’ returned non-zero exit status 1
[root@localhost ~]# sudo python install.py --develop --user frappe
Loaded plugins: fastestmirror, langpacks
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
yumclient | 2.9 kB 00:00
Loading mirror speeds from cached hostfile
Warning: group Development tools does not exist.
Maybe run: yum groups mark install (see man yum)
Error: No packages in any requested group available to install or update
Traceback (most recent call last):
File “install.py”, line 417, in
install_bench(args)
File “install.py”, line 21, in install_bench
‘sudo yum install -y epel-release redhat-lsb-core git python-setuptools python-devel openssl-devel libffi-devel’
File “install.py”, line 234, in run_os_command
returncode = subprocess.check_call(command, shell=True)
File “/usr/lib64/python2.7/subprocess.py”, line 542, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo yum groupinstall -y “Development tools”’ returned non-zero exit status 1

yum clean all
yum groupinstall "Development tools"

root@162-144-54-30.bluehost-in.com [home]# python install.py --develop --user frappe
Sorry, the installer doesn’t support centos 6. Aborting installation!
Install on centos 7 instead
root@162-144-54-30.bluehost-in.com [home]# sudo python install.py --production
Sorry, the installer doesn’t support centos 6. Aborting installation!
Install on centos 7 instead
root@162-144-54-30.bluehost-in.com [home]#

Version of your Centos?

we have two versions of centos 6 (2.6.32-696.18.7.el6.x86_64) , and Centos7
(3.10.0-693.el7.x86_64)

send log of Centos7

Please install on centos 7. And any specific reason you’re trying to install manually instead of using the easy install scripts ?