Installation Issue

Hello,

I followed the instructions posted at https://github.com/frappe/frappe-bench/blob/master/Readme.md and I did not see a single error. I was able to start the ERPNext application in development as specified in that page and connect to the application on port 8000. When I started supervisor and nginx (using sudo on Ubuntu 14.04 server), everything went well and again I did not see any problems. I executed the production deployment scripts and they were copied fine.

I restarted the server and instead of being able to access ERPNext on port 80, I get a page not found error. Can you please point me as to what could be wrong? For your info, it is a virtual server on VirtualBox and is fully connected to my LAN.

Thanks,

Sultan



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/36db81de-f69b-4903-b836-f67b9159e2aa%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, May 27, 2014 at 8:21 PM, Sultan Ghaznawi
su...@gmail.com wrote:

Hello,

I followed the instructions posted at
https://github.com/frappe/frappe-bench/blob/master/Readme.md and I did not
see a single error. I was able to start the ERPNext application in
development as specified in that page and connect to the application on port
8000. When I started supervisor and nginx (using sudo on Ubuntu 14.04
server), everything went well and again I did not see any problems. I
executed the production deployment scripts and they were copied fine.

I restarted the server and instead of being able to access ERPNext on port
80, I get a page not found error. Can you please point me as to what could
be wrong? For your info, it is a virtual server on VirtualBox and is fully
connected to my LAN.

Maybe supervisor is not running. What does supervisorctl status say?

Thanks,

Sultan


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/36db81de-f69b-4903-b836-f67b9159e2aa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Pratik
erpnext

I can not run that command without sudo (gives me a permission denied error), when I do use sudo I see that it is running:

frappe:frappe-web                  RUNNING ...
frappe:frappe-worker              RUNNING ...
frappe:frappe-workerbeat        RUNNING ...

Does this mean that the application is not running?

Sultan



On Tuesday, May 27, 2014 11:02:30 AM UTC-4, Pratik Vyas wrote:
On Tue, May 27, 2014 at 8:21 PM, Sultan Ghaznawi
<su...@gmail.com> wrote:
> Hello,
>
> I followed the instructions posted at
> https://github.com/frappe/frappe-bench/blob/master/Readme.md and I did not
> see a single error. I was able to start the ERPNext application in
> development as specified in that page and connect to the application on port
> 8000. When I started supervisor and nginx (using sudo on Ubuntu 14.04
> server), everything went well and again I did not see any problems. I
> executed the production deployment scripts and they were copied fine.
>
> I restarted the server and instead of being able to access ERPNext on port
> 80, I get a page not found error. Can you please point me as to what could
> be wrong? For your info, it is a virtual server on VirtualBox and is fully
> connected to my LAN.
>

Maybe supervisor is not running. What does `supervisorctl status` say?
> Thanks,
>
> Sultan
>
> --
> Note:
>
> If you are posting an issue,
> 1. We should be able to replicate it at our end. So please give us as much
> information as you can. Please see it from the point of view of the person
> receiving the communication.
> 2. Paste your code at http://pastebin.com or http://gist.github.com and send
> only the URL via email
> 3. For sending images, use http://imgur.com or other similar services. Do
> not send images as attachments. Links are good. Same goes for any file you
> are going to send.
>
> End of Note
> ---
> You received this message because you are subscribed to the Google Groups
> "ERPNext Developer Forum" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to erpnext-developer-forum+un...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/erpnext-developer-forum/36db81de-f69b-4903-b836-f67b9159e2aa%40googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.



--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/b5166635-bbd2-4abf-817a-07e14e69627f%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, May 27, 2014 at 8:42 PM, Sultan Ghaznawi
su...@gmail.com wrote:

I can not run that command without sudo (gives me a permission denied
error), when I do use sudo I see that it is running:

frappe:frappe-web RUNNING …
frappe:frappe-worker RUNNING …
frappe:frappe-workerbeat RUNNING …

Does this mean that the application is not running?

Sultan

Is nginx running? service nginx status-


Pratik
erpnext

Oh, this command tells me that nginx is not running. Do I need to make any customization to any config files? I ran the config file copy at the end of the installation guide.

On Tuesday, May 27, 2014 11:21:00 AM UTC-4, Pratik Vyas wrote:
On Tue, May 27, 2014 at 8:42 PM, Sultan Ghaznawi
<su...@gmail.com> wrote:
> I can not run that command without sudo (gives me a permission denied
> error), when I do use sudo I see that it is running:
>
> frappe:frappe-web                  RUNNING ...
> frappe:frappe-worker              RUNNING ...
> frappe:frappe-workerbeat        RUNNING ...
>
> Does this mean that the application is not running?
>
> Sultan
>
>
Is nginx running? `service nginx status-`

--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/fc544b36-3b1e-4186-855b-5980d8222ddf%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, May 27, 2014 at 8:55 PM, Sultan Ghaznawi
su...@gmail.com wrote:

Oh, this command tells me that nginx is not running. Do I need to make any
customization to any config files? I ran the config file copy at the end of
the installation guide.

you can run sudo update-rc.d nginx defaults to run it on boot
(please check if this works). You can start nginx manually using
service nginx start


Pratik
erpnext

Hi Pratik,

The 'sudo update-rc.d nginx defaults' responds that it already exists and the start manual start command simply returns without any errors but the status check shows that the service is not started regarding of whether the command is run by sudo or user.

Another thing to note, probably could be the issue is that when I ran './scripts/install.sh single [sitename [dbname]]' command I kept the brackets in place such as '... [mysitename [mydbname]]'. I think that was a mistake and created some problem. Can you confirm?

Thanks,

Sultan

On Tuesday, May 27, 2014 11:28:05 AM UTC-4, Pratik Vyas wrote:
On Tue, May 27, 2014 at 8:55 PM, Sultan Ghaznawi
<su...@gmail.com> wrote:
> Oh, this command tells me that nginx is not running. Do I need to make any
> customization to any config files? I ran the config file copy at the end of
> the installation guide.
>
>
you can run `sudo update-rc.d nginx defaults` to run it on boot
(please check if this works). You can start nginx manually using
`service nginx start`

--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/d47a47f2-a9cb-4496-90ba-cd5777079555%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, May 27, 2014 at 9:01 PM, Sultan Ghaznawi
su...@gmail.com wrote:

Hi Pratik,

The ‘sudo update-rc.d nginx defaults’ responds that it already exists and
the start manual start command simply returns without any errors but the
status check shows that the service is not started regarding of whether the
command is run by sudo or user.

Then it should have started on boot automatically.

Another thing to note, probably could be the issue is that when I ran
‘./scripts/install.sh single [sitename [dbname]]’ command I kept the
brackets in place such as ‘… [mysitename [mydbname]]’. I think that was a
mistake and created some problem. Can you confirm?

That would have created the database name and site directory with the brackets.

Thanks,

Sultan

On Tuesday, May 27, 2014 11:28:05 AM UTC-4, Pratik Vyas wrote:

On Tue, May 27, 2014 at 8:55 PM, Sultan Ghaznawi
su...@gmail.com wrote:

Oh, this command tells me that nginx is not running. Do I need to make
any
customization to any config files? I ran the config file copy at the end
of
the installation guide.

you can run sudo update-rc.d nginx defaults to run it on boot
(please check if this works). You can start nginx manually using
service nginx start


Pratik
erpnext


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/d47a47f2-a9cb-4496-90ba-cd5777079555%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Pratik
erpnext

OK, so nginx didn't start on boot and apparently the brackets should be fine. What do you suggest I do next to get this started?

when I ran netstat I see that something is listening to port 8000 and when I did a filter on 'http' for netstat, the box returns nothing.

Any suggestions?



On Tuesday, May 27, 2014 11:35:38 AM UTC-4, Pratik Vyas wrote:
On Tue, May 27, 2014 at 9:01 PM, Sultan Ghaznawi
<su...@gmail.com> wrote:
> Hi Pratik,
>
> The 'sudo update-rc.d nginx defaults' responds that it already exists and
> the start manual start command simply returns without any errors but the
> status check shows that the service is not started regarding of whether the
> command is run by sudo or user.

Then it should have started on boot automatically.

>
> Another thing to note, probably could be the issue is that when I ran
> './scripts/install.sh single [sitename [dbname]]' command I kept the
> brackets in place such as '... [mysitename [mydbname]]'. I think that was a
> mistake and created some problem. Can you confirm?


That would have created the database name and site directory with the brackets.
>
> Thanks,
>
> Sultan
>
>
> On Tuesday, May 27, 2014 11:28:05 AM UTC-4, Pratik Vyas wrote:
>>
>> On Tue, May 27, 2014 at 8:55 PM, Sultan Ghaznawi
>> <su...@gmail.com> wrote:
>> > Oh, this command tells me that nginx is not running. Do I need to make
>> > any
>> > customization to any config files? I ran the config file copy at the end
>> > of
>> > the installation guide.
>> >
>> >
>> you can run `sudo update-rc.d nginx defaults` to run it on boot
>> (please check if this works). You can start nginx manually using
>> `service nginx start`
>>
>> --
>> Pratik
>> erpnext
>
> --
> Note:
>
> If you are posting an issue,
> 1. We should be able to replicate it at our end. So please give us as much
> information as you can. Please see it from the point of view of the person
> receiving the communication.
> 2. Paste your code at http://pastebin.com or http://gist.github.com and send
> only the URL via email
> 3. For sending images, use http://imgur.com or other similar services. Do
> not send images as attachments. Links are good. Same goes for any file you
> are going to send.
>
> End of Note
> ---
> You received this message because you are subscribed to the Google Groups
> "ERPNext Developer Forum" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to erpnext-developer-forum+un...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/erpnext-developer-forum/d47a47f2-a9cb-4496-90ba-cd5777079555%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.



--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/ba40d5a1-8cb0-45e5-9b18-eb51ffa13579%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, May 27, 2014 at 9:08 PM, Sultan Ghaznawi
su...@gmail.com wrote:

OK, so nginx didn’t start on boot and apparently the brackets should be
fine. What do you suggest I do next to get this started?

As I mentioned earlier, service nginx start should start it.

when I ran netstat I see that something is listening to port 8000 and when I
did a filter on ‘http’ for netstat, the box returns nothing.

That is gunicorn (WSGI server that powers ERPNext).


Pratik
erpnext