Try ERPNext Buy Support Partners Foundation

Installation issue on ubuntu 20.04.1 LTS

Greetings ,
i’m totally new to ERPNext . tried to install on centos and now trying Ubuntu 20.04.1 LTS after reading some post that ubuntu is easier in terms of installation .

in short i followed the below guide to install

when i reached the line to create new web site using the below command it fails with the below error

$bench new-site erpnext.mysite

Error :- Creation of your site - erpnext.mysite failed because MariaDB is not properly
configured. If using version 10.2.x or earlier, make sure you use the
the Barracuda storage engine.

Please verify the settings above in MariaDB’s my.cnf. Restart MariaDB. And
then run bench new-site erpnext.localhost again.

google search didn’t help alot as from my understanding the bench command is related to erpnext frame work .

i’m installing on cloud
Ubuntu 20.04.1 LTS
1 core
15 GB Ram
60GB Storage

can someone help please ?

See this post/article

@SHassan

Did you try using easy install script ?

Let me know if you need more support.

@Nikunj_Patel ,
no i did not , don’t know where to find working one , also does it work on centos ?

i’m not able to install through the easy install or the manual one , on ubuntu 20.04 or ubuntu16.04 or centos 7.8 , i’m really bad with python , couldn’t even track the problem , seems dead end