ERPNext Conference 2019* ERPNext.com Blog

Installation help for Ubuntu 16.04


#1

We have taken all the suggestions each one presented issues some of which we have posted here in the forum.
Here are the types of install tested:
virtualbox
production install script
manual install

We have done the research but yet have had to jump through hoops to install because there have been changes in syntax, bugs/development, and outdated instructions that are not congruent with what we are experiencing with ver7 on Ubuntu 16.04.

A simple step by step guide specific to ver7 Ubuntu or for that matter any other distro that addresses issues with frappe user permissions, proper non root install, and then how to change site name and host name properly in multitenant with out errors. Many of the bench commands referenced on this pagehttps://frappe.github.io/frappe/user/en/bench/resources/bench-commands-cheatsheet.html and the forums just don’t work no matter where and whom they are executed by.

We are capable of searching the forum and docs, which since we are logged in you should have visibility to the metrics to see the time searched to see we have been diligent. We have found solutions to fix one problem only to be presented with another.

We fully understand that this is open source so we are certainly trying to work within that expectation level and are very grateful for all the work done but is very hard to navigate this product so that we can get a working and viable solution so we can begin to give back…

We will say that if we do not care if its not named oursite.domain.com or do not need ssl we can get a working copy on the localhost but if we want to modify just about anything incorrect commands, permission issues and errors abound…

If we have somehow missed the relevant definitive guide for ver7 and unbuntu than take this post for what it is a user’s experience and their desire to find a solution that doesn’t appear obvious for what looks like an excellent solution.


#2

#3

@imllc sorry about this.

Please post specific queries on where an install breaks.

We generally recommend a clean system to do an install. If you have existing configs, then the help may vary.


#4

ok because Ubuntu seems to be elusive I decided to go back to a build I have worked with in the past Centos. I followed the post here Installing ErpNext on CentOs 7 - Guide with moderator modifications and had the same frappe issue, no password and no site.

If I had the frappe password I suppose I could have installed as production site despite the easy method stating it should be installed.

This is very frustrating as my original post suggest.

Can we get a real definitive step by step install for version 7 for Centos7 and Ubuntu 16.04 so we can make an informed decision on this product without reinventing the wheel?


#5

@imllc I just ran the two commands below on centos 7 and ubuntu and they installed and ran fine. Are you starting form a fresh os install?

wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py

sudo python install.py --develop


#6

I do not want develop I want production… when I ran as such I had no site1 and I still can not locate frappe password which handicaps any correction to a bad eayscript/install


#7

I can’t speak of anything else, but regarding passwords, in the new ansible playbooks, you are the one who sets the passwords - it asks for the passwords you want to use during the process - there is no autogenerated password anywhere.

Also, people will be able to help better if you specifically tell the steps you are doing and what the outcome was - linking to other threads and telling that you are doing things or running things without telling exactly what commands you are running doesn’t really clarify anything.

Try to tell specifically what you are doing - here is an example

  1. On a fresh CentOS 7 install, i run the following command some command here
  2. Then i run some command. the output is `some output
  3. etc

#8

@imllc here is the page (below) that gives you the install info and @felix is right you set all of the passwords in the script

https://github.com/frappe/bench

If you want production this is it

wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py

For production

sudo python install.py --production


#9

All of the doc say run as frappe but it does not ask for frappe password in install, just administrator and MySQL. As a test I used the same password for all entries and then I use su frappe to run bench from root the password is incorrect which leads me to believe its auto generated or the doc on how to run bench to accomplish task is outdated.


#10

assuming you’re passing the argument --user=frappe during install, there shouldn’t be a password for the frappe OS user.

Regardless, since you have root access, you can easily change/set the password for the user

while in root, run passwd frappe to set your password and you’ll be on your way.

http://www.tldp.org/LDP/lame/LAME/linux-admin-made-easy/changing-user-passwords.html


#11

I just ran these scripts in AWS and worked perfectly on Ubuntu 14.4, have also installed it on CentOS 7 previously without issues.

If you want production this is it

wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py

For production

sudo python install.py --production