Install problem when running "Easy Way" script on Univention Corporate Server

I commented out:

elif [ -f /etc/lsb-release ]; then
. /etc/lsb-release
OS=$DISTRIB_ID
OS_VER=$DISTRIB_CODENAME

so that the installer script would recognize the OS as wheezy but still ran in to following problem:

Installing for debian 7 amd64
In case you encounter an error, you can post on https://discuss.frappe.io

Adding debian mariadb repo
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 160, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 96, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 584, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)    
  File "/usr/lib/python2.7/dist-packages/aptsources/distro.py", line 87, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

Can someone help?

Recipe for trouble! Try installing the per-requisites manually.

Rushabh

I followed your advice to a point but I am stuck again. I would appreciate some assistance.

‘bench start’ give s the following result:

19:18:47 redis_async_broker.1 | [11273] 07 Dec 19:18:46 # Fatal error, can’t open config file 'config/redis_async_broker.conf’

Looking at the redis process shows that it was started using a different .conf file

root@ucs-1:/home/frappe/frappe-bench/config# ps aux | grep redis
redis 3821 0.0 0.0 35924 3192 ? Ssl 18:43 0:02 /usr/bin/redis-server /etc/redis/redis.conf
root 14840 0.0 0.0 9248 1960 pts/0 S+ 19:47 0:00 grep redis

Was I supposed to set up a specific one for bench or just copy/sym link the default?

I am very clueless about bench and supervisor (among many other things! :wink: ) is there a detailed explanation of how to use these tools after configuring everything correctly

http://supervisord.org/

I manually installed on ubuntu 15.10.
As mentioned, I installed prerequisites manually, choosing versions and packages appropriately from default repos.

check thread if it helps Installation on Ubuntu 15.10

I’ve not tried this on Debian 8 yet.