Try ERPNext Buy Support Partners Foundation

Install guide based on Ubuntu 18.4 and Python3

I followed a Install guide for Ubuntu 18.4 and tried to use python3.
This failed.
Is there a proven installation guide for Ubunut 18.04 and Python3 and the latest ERPNext 12.06 .
In the meantime I will try the hint provided by Joseph Marii Alba

Joseph_Marie_Alba

1 Like

It would help if you posted details of what failed. This would help strengthen the guide and be useful to others that may have similar problems you had.

Also, a link to the guide and hints you refer to will help others too.

This worked for me yesterday:

1 Like

Attached is a document describing my installation process.

I tried to follow carefully what I found in a new guide and my notes of appr. 6 months ago when the installation went well.

Now the installation crashes with redis connection issue.

The main question is why there is not a proven installation how to.

The second question is if I did something wrong or if the installation procedure is buggy.

Met vriendelijke groeten, Kind regards,

``
Frank Messie

Braedius
Medical

Braedius Medical BV
Bikbergerweg 18
1272 PM Huizen,The Netherlands
Email: frank.messie@braedius.com
Phone: +31(0)358876100
Mobile: +31654665520
Web: www.braedius.com

(Attachment erpnext-installation-20200323.doc is missing)

I have documented carefully the procedure I followed and what went wrong in a document but it seems that cannot upload that document . Not very nice or am I missing something?

Thank you Frank.

Your document is missing. Try sending it some other way.

Unfortunately, the installer cannot be in controller of all dependencies. Redis is of of them. Redis is used for caching, and is a third party software that ErpNext depends on. It may have it’s own set of issues. As an example, you could install Mariadb or myssql and this could be broken for many reasons, causing the install to not proceed.

In fairness, without seeing the results of your install attempt, it might be difficult to say what the issue is.

When I installed I also had an issue with redis. I took the command the installer ran to start the redis service, and ran this on the command line itself, without Erpnext. This gave me clues to what the issue was. In my case, I fixed permissions and started the redis server

sudo service redis start

Hope you can resolve the issue.