Install errors on Beta Develop Setup

I have a keep trying a fresh install of ubuntu 14.4 using GCP

sudo apt-get update && sudo apt-get upgrade

wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup
_frappe.sh

sudo bash setup_frappe.sh --setup-production

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
npm : Depends: nodejs but it is not going to be installed
Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
Depends: node-ansi-color-table but it is not going to be installed
Depends: node-archy but it is not going to be installed
Depends: node-block-stream but it is not going to be installed
Depends: node-fstream (>= 0.1.22) but it is not going to be installed
Depends: node-fstream-ignore but it is not going to be installed
Depends: node-github-url-from-git but it is not going to be installed
Depends: node-glob (>= 3.1.21) but it is not going to be installed
Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
Depends: node-inherits but it is not going to be installed
Depends: node-ini (>= 1.1.0) but it is not going to be installed
Depends: node-lockfile but it is not going to be installed
Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
Depends: node-gyp (>= 0.10.9) but it is not going to be installed
Depends: node-nopt (>= 3.0.1) but it is not going to be installed
Depends: node-npmlog but it is not going to be installed
Depends: node-once but it is not going to be installed
Depends: node-osenv but it is not going to be installed
Depends: node-read but it is not going to be installed
Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
Depends: node-request (>= 2.25.0) but it is not going to be installed
Depends: node-retry but it is not going to be installed
Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
Depends: node-semver (>= 2.1.0) but it is not going to be installed
Depends: node-sha but it is not going to be installed
Depends: node-slide but it is not going to be installed
Depends: node-tar (>= 0.1.18) but it is not going to be installed
Depends: node-underscore but it is not going to be installed
Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any help please?

Try using the beta script https://github.com/frappe/bench#beta-development-setup

Thanks for your reply.

I have tried the Beta Develop Setup

wget https://raw.githubusercontent.com/frappe/bench/develop/playbooks/install.py

python install.py --develop

And got this:

ERROR! Unexpected Exception: (setuptools 5.5.1 (/usr/lib/python2.7/dist-packages), Requirement.parse(‘setuptools>=1
1.3’))
the full traceback was:

Traceback (most recent call last):
File “/usr/local/bin/ansible-playbook”, line 73, in
mycli = getattr(import(“ansible.cli.%s” % sub, fromlist=[myclass]), myclass)
File “/usr/local/lib/python2.7/dist-packages/ansible/cli/playbook.py”, line 30, in
from ansible.executor.playbook_executor import PlaybookExecutor
File “/usr/local/lib/python2.7/dist-packages/ansible/executor/playbook_executor.py”, line 27, in
from ansible.executor.task_queue_manager import TaskQueueManager
File “/usr/local/lib/python2.7/dist-packages/ansible/executor/task_queue_manager.py”, line 28, in
from ansible.executor.play_iterator import PlayIterator
File “/usr/local/lib/python2.7/dist-packages/ansible/executor/play_iterator.py”, line 29, in
from ansible.playbook.block import Block
File “/usr/local/lib/python2.7/dist-packages/ansible/playbook/init.py”, line 25, in
from ansible.playbook.play import Play
File “/usr/local/lib/python2.7/dist-packages/ansible/playbook/play.py”, line 27, in
from ansible.playbook.base import Base
File “/usr/local/lib/python2.7/dist-packages/ansible/playbook/base.py”, line 35, in
from ansible.parsing.dataloader import DataLoader
File “/usr/local/lib/python2.7/dist-packages/ansible/parsing/dataloader.py”, line 32, in
from ansible.parsing.vault import VaultLib
File “/usr/local/lib/python2.7/dist-packages/ansible/parsing/vault/init.py”, line 67, in
from cryptography.hazmat.primitives.hashes import SHA256 as c_SHA256
File “/usr/local/lib/python2.7/dist-packages/cryptography/hazmat/primitives/hashes.py”, line 15, in
from cryptography.hazmat.backends.interfaces import HashBackend
File “/usr/local/lib/python2.7/dist-packages/cryptography/hazmat/backends/init.py”, line 7, in
import pkg_resources
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2876, in
working_set = WorkingSet._build_master()
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 451, in _build_master
return cls._build_from_requirements(requires)
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 464, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 644, in resolve
raise VersionConflict(dist, req)
VersionConflict: (setuptools 5.5.1 (/usr/lib/python2.7/dist-packages), Requirement.parse(‘setuptools>=11.3’))
Traceback (most recent call last):
File “install.py”, line 261, in
install_bench(args)
File “install.py”, line 76, in install_bench
run_playbook(‘develop/create_user.yml’, extra_vars=extra_vars)
File “install.py”, line 214, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(tmp_bench_repo, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘develop/create_user.yml’, ‘-e’, ‘@/tmp
/extra_vars.json’]’ returned non-zero exit status 250

So I tried…

sudo pip install setuptools==11.3

And am now stuck here :frowning:

Collecting setuptools==11.3
Downloading setuptools-11.3-py2.py3-none-any.whl (500kB)
100% |████████████████████████████████| 501kB 2.3MB/s
Installing collected packages: setuptools
Found existing installation: setuptools 23.1.0
Uninstalling setuptools-23.1.0:
Successfully uninstalled setuptools-23.1.0
Successfully installed setuptools
Traceback (most recent call last):
File “/usr/local/bin/pip”, line 11, in
sys.exit(main())
File “/usr/local/lib/python2.7/dist-packages/pip/init.py”, line 221, in main
return command.main(cmd_args)
File “/usr/local/lib/python2.7/dist-packages/pip/basecommand.py”, line 252, in main
pip_version_check(session)
File “/usr/local/lib/python2.7/dist-packages/pip/utils/outdated.py”, line 102, in pip
_version_check
installed_version = get_installed_version(“pip”)
File “/usr/local/lib/python2.7/dist-packages/pip/utils/init.py”, line 848, in get
_installed_version
working_set = pkg_resources.WorkingSet()
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 619, in init
self.add_entry(entry)
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 675, in add_entry
for dist in find_distributions(entry, True):
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 1942, in find_eggs_in_zip
if metadata.has_metadata(‘PKG-INFO’):
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 1463, in has_metadata
return self.egg_info and self._has(self._fn(self.egg_info, name))
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 1824, in _has
return zip_path in self.zipinfo or zip_path in self._index()
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 1704, in zipinfo
return self._zip_manifests.load(self.loader.archive)
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/init.py”,
line 1644, in load
mtime = os.stat(path).st_mtime
OSError: [Errno 2] No such file or directory: ‘/root/.local/lib/python2.7/site-packages
/setuptools-23.1.0-py2.7.egg’

Stuck again lol thanks again

I think I am actually good now with that.

I ran…

python install.py --develop

and get:

“[WARNING]: Host file not found: /etc/ansible/hosts
[WARNING]: provided hosts list is empty, only localhost is available”

Yep; I spent more that 10 DAYS across more than 5 linux distro to find out that, someone has been misplaced the order of apt-get install CURL! within the install script.

for fresh install of ubuntu 14.4 please install CURL before you proceed with the script.

My story is similar, I keep trying different distros and install methods with no really luck.

sudo apt-get install curl
Reading package lists… Done
Building dependency tree
Reading state information… Done
curl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Says I already have CURL

Do I need to uninstall python3?

Still getting…

"[WARNING]: Host file not found: /etc/ansible/hosts
[WARNING]: provided hosts list is empty, only localhost is available

When running

python install.py --develop

python3 --version
Python 3.4.2
which python
/usr/bin/python
/usr/bin/python --version
Python 2.7.9

Probably, since ERPNext runs on 2.7

It may be creating conflicts.

So it doesn’t seem like this is resolved here and nobody posted the real fix. I have the same problem and posted it in Error during Beta Development Setup in Ubuntu 14