Install erpnext problem

Hi all,

I have these message when I install erpnext in a site

bench install-app erpnext
Installing erpnext…
Updating DocTypes for erpnext : [==== ]Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/mayssaa/demo/apps/frappe/frappe/utils/bench_helper.py”, line 79, in
main()
File “/home/mayssaa/demo/apps/frappe/frappe/utils/bench_helper.py”, line 16, in main
click.Group(commands=commands)(prog_name=‘bench’)
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/mayssaa/demo/env/local/lib/python2.7/site-packages/click/decorators.py”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/mayssaa/demo/apps/frappe/frappe/commands/init.py”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/mayssaa/demo/apps/frappe/frappe/commands/site.py”, line 153, in install_app
_install_app(app, verbose=context.verbose)
File “/home/mayssaa/demo/apps/frappe/frappe/installer.py”, line 134, in install_app
sync_for(name, force=True, sync_everything=True, verbose=verbose, reset_permissions=True)
File “/home/mayssaa/demo/apps/frappe/frappe/model/sync.py”, line 45, in sync_for
reset_permissions=reset_permissions)
File “/home/mayssaa/demo/apps/frappe/frappe/modules/import_file.py”, line 58, in import_file_by_path
ignore_version=ignore_version, reset_permissions=reset_permissions)
File “/home/mayssaa/demo/apps/frappe/frappe/modules/import_file.py”, line 129, in import_doc
doc.insert()
File “/home/mayssaa/demo/apps/frappe/frappe/model/document.py”, line 220, in insert
self.run_post_save_methods()
File “/home/mayssaa/demo/apps/frappe/frappe/model/document.py”, line 784, in run_post_save_methods
self.run_method(“on_update”)
File “/home/mayssaa/demo/apps/frappe/frappe/model/document.py”, line 663, in run_method
out = Document.hook(fn)(self, *args, **kwargs)
File “/home/mayssaa/demo/apps/frappe/frappe/model/document.py”, line 884, in composer
return composed(self, method, *args, **kwargs)
File “/home/mayssaa/demo/apps/frappe/frappe/model/document.py”, line 867, in runner
add_to_return_value(self, fn(self, *args, **kwargs))
File “/home/mayssaa/demo/apps/frappe/frappe/model/document.py”, line 657, in
fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
File “/home/mayssaa/demo/apps/frappe/frappe/core/doctype/doctype/doctype.py”, line 202, in on_update
self.run_module_method(“on_doctype_update”)
File “/home/mayssaa/demo/apps/frappe/frappe/core/doctype/doctype/doctype.py”, line 231, in run_module_method
module = load_doctype_module(self.name, self.module)
File “/home/mayssaa/demo/apps/frappe/frappe/modules/utils.py”, line 184, in load_doctype_module
raise ImportError, ‘Module import failed for {0} ({1})’.format(doctype, module_name)
ImportError: Module import failed for Payment Request (erpnext.accounts.doctype.payment_request.payment_request)

what i can do?
Thanx

try this
bench new-site somesite
bench --site somesite install-app erpnext

thank u @MCD-50

I try it, the problem is still appear
I think there is a problem in payment_request doctype in the copy of erpnext that is in the githup https://github.com/frappe/erpnext

Are you use develop or production. I look, you use develop.

yes I use develop mode
I switched to branch master and it is work now