ImportError when running frappe [site] --install_app [app]

I installed a modified version of ERPNext by replacing the erpnext folder in ~/frappe-bench/apps/ with one containing the new code, and I am using the Developer Guide to help me set up the site for it. I keep getting stuck at step 2.4, however. When I try to run frappe erpnext --install_app erpnext, I get this ImportError traceback.

Is this not the correct way to do this? How can I fix it? Thanks in advance.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/ad3cb7c7-5c37-438f-bc56-b9202e91361f%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
Actually, this might be due to us receiving code which was built on ERPNext 3.6.1, while we're trying to use it like an ERPNext 4.0.1 application. We have contacted the developer of the modified code and hopefully they can work on this further with us.

On Thursday, June 19, 2014 10:47:34 AM UTC-4, Chris Horton wrote:
I installed a modified version of ERPNext by replacing the erpnext folder in ~/frappe-bench/apps/ with one containing the new code, and I am using the Developer Guide to help me set up the site for it. I keep getting stuck at step 2.4, however. When I try to run frappe erpnext --install_app erpnext, I get this ImportError traceback.

Is this not the correct way to do this? How can I fix it? Thanks in advance.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/e4c3da50-a87d-4376-8d78-a049480b9243%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.