Ignore Pricing Rule Option

Dear All,

The "Ignore Pricing Rule" checkbox is not available either within the Sales Quotation or the Sales Order. Is there a settings that is required to be activated for the checkbox to be made available?

Thank you.



Javier



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d9b9ec6b-8ddf-4828-98a0-5d1392bcc141%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

May be you have hidden that field via Setup -> Customize Form. There are no other settings to hide that field.

On Aug 4, 2014, at 5:09 PM, Javier <bo...@gmail.com> wrote:

Dear All,

The "Ignore Pricing Rule" checkbox is not available either within the Sales Quotation or the Sales Order. Is there a settings that is required to be activated for the checkbox to be made available?

Thank you.



Javier



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d9b9ec6b-8ddf-4828-98a0-5d1392bcc141%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

<Ignore Pricing Rule.jpg>




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/50DC7CCA-63DD-45A4-A15A-C78AC8E5CBCF%40iwebnotes.com.

For more options, visit https://groups.google.com/d/optout.

Dear Nabin,

Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.

Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?

Thanks real much


You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.

So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.

On Aug 4, 2014, at 6:01 PM, Javier bo...@gmail.com wrote:

Dear Nabin,

Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.

Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?

Thanks real much


You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/C720FEFF-5E6C-4C42-A000-DD50549414E4%40iwebnotes.com.
For more options, visit https://groups.google.com/d/optout.

Dear Nabin,

I tried to assign Sales Manager to a particular User ID which ONLY has the Sales Manager role but still can not see the checkbox. I have not modified any of the standard default roles. Any other clues?

FYI I am using the virtual box download with all updates performed. Thanks real much.


Javier


On Monday, August 4, 2014 8:49:01 PM UTC+8, Nabin Hait wrote:
Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.

So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.

On Aug 4, 2014, at 6:01 PM, Javier <bo...@gmail.com> wrote:

> Dear Nabin,
>
> Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.
>
> Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?
>
> Thanks real much
>
> --
> You received this message because you are subscribed to the Google Groups "ERPNext User's Forum" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/72f0bdf4-8700-446f-9777-71cd537cc0fd%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Dear Nabin,

I think I've worked out how to get this working. Basically the DEFAULT Sales Manager and all other Managers don't have level 1 permissions set in the Role Permissions and when I added them manually I could then see the option. Thanks for giving me an idea on where to look.

Just to check, is it true that the default role permissions dont grant level 1 access for those Manager roles?

Thank you.


On Tuesday, August 5, 2014 12:34:15 PM UTC+8, Javier wrote:
Dear Nabin,

I tried to assign Sales Manager to a particular User ID which ONLY has the Sales Manager role but still can not see the checkbox. I have not modified any of the standard default roles. Any other clues?

FYI I am using the virtual box download with all updates performed. Thanks real much.


Javier


On Monday, August 4, 2014 8:49:01 PM UTC+8, Nabin Hait wrote:
Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.

So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.

On Aug 4, 2014, at 6:01 PM, Javier <bo...@gmail.com> wrote:

> Dear Nabin,
>
> Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.
>
> Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?
>
> Thanks real much
>
> --
> You received this message because you are subscribed to the Google Groups "ERPNext User's Forum" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/98600fb1-f658-415f-8bd3-d1a55828d253%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi Javier.

The default permissions have level 1 grants. But we don't override your permission customizations unless you explicitly reset the permissions in Role Permissions Manager.


Thanks,
Anand.



On Tue, Aug 5, 2014 at 1:41 PM, Javier <bo…@gmail.com> wrote:
Dear Nabin,

I think I've worked out how to get this working. Basically the DEFAULT Sales Manager and all other Managers don't have level 1 permissions set in the Role Permissions and when I added them manually I could then see the option. Thanks for giving me an idea on where to look.

Just to check, is it true that the default role permissions dont grant level 1 access for those Manager roles?

Thank you.


On Tuesday, August 5, 2014 12:34:15 PM UTC+8, Javier wrote:
Dear Nabin,

I tried to assign Sales Manager to a particular User ID which ONLY has the Sales Manager role but still can not see the checkbox. I have not modified any of the standard default roles. Any other clues?

FYI I am using the virtual box download with all updates performed. Thanks real much.


Javier


On Monday, August 4, 2014 8:49:01 PM UTC+8, Nabin Hait wrote:

Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.



So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.



On Aug 4, 2014, at 6:01 PM, Javier <bo…@gmail.com> wrote:



> Dear Nabin,

>

> Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.

>

> Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?

>

> Thanks real much

>

> –

> You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

> To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

> To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.

> For more options, visit https://groups.google.com/d/optout.





You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/98600fb1-f658-415f-8bd3-d1a55828d253%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/CAAQzbF0aSg1xnd6xh%2BGC1d8vCN3OA5J%3DxZYxrvdx1f5csLjZEA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

Dear Anand,

Thanks for this information. For some odd reason my default install does not have any Level 1 permissions for Sales Manager --> Sales Order or Quotation (for example). Is there a way I can completely reset the permissions for all roles and all document types?

Thank you.


Javier

On Tuesday, August 5, 2014 4:43:14 PM UTC+8, Anand Doshi wrote:
Hi Javier.

The default permissions have level 1 grants. But we don't override your permission customizations unless you explicitly reset the permissions in Role Permissions Manager.


Thanks,
Anand.



On Tue, Aug 5, 2014 at 1:41 PM, Javier <bo…@gmail.com> wrote:
Dear Nabin,

I think I've worked out how to get this working. Basically the DEFAULT Sales Manager and all other Managers don't have level 1 permissions set in the Role Permissions and when I added them manually I could then see the option. Thanks for giving me an idea on where to look.

Just to check, is it true that the default role permissions dont grant level 1 access for those Manager roles?

Thank you.


On Tuesday, August 5, 2014 12:34:15 PM UTC+8, Javier wrote:
Dear Nabin,

I tried to assign Sales Manager to a particular User ID which ONLY has the Sales Manager role but still can not see the checkbox. I have not modified any of the standard default roles. Any other clues?

FYI I am using the virtual box download with all updates performed. Thanks real much.


Javier


On Monday, August 4, 2014 8:49:01 PM UTC+8, Nabin Hait wrote:

Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.



So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.



On Aug 4, 2014, at 6:01 PM, Javier <bo…@gmail.com> wrote:



> Dear Nabin,

>

> Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.

>

> Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?

>

> Thanks real much

>

> –

> You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

> To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

> To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.

> For more options, visit https://groups.google.com/d/optout.





You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/98600fb1-f658-415f-8bd3-d1a55828d253%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/1cb458f7-bf3c-4c73-b34d-b78a9e37e7de%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi Javier,

You can do that via command line, after activating environment, using:
frappe [sitename] --reset_perms

If you are using the new bench, you can prepend the command with bench, which activates the environment for you and runs the command too:

bench frappe [sitename] --reset_perms


Thanks,
Anand.


On Tue, Aug 5, 2014 at 2:49 PM, Javier <bo…@gmail.com> wrote:
Dear Anand,

Thanks for this information. For some odd reason my default install does not have any Level 1 permissions for Sales Manager --> Sales Order or Quotation (for example). Is there a way I can completely reset the permissions for all roles and all document types?

Thank you.


Javier


On Tuesday, August 5, 2014 4:43:14 PM UTC+8, Anand Doshi wrote:
Hi Javier.

The default permissions have level 1 grants. But we don't override your permission customizations unless you explicitly reset the permissions in Role Permissions Manager.


Thanks,
Anand.



On Tue, Aug 5, 2014 at 1:41 PM, Javier <bo…@gmail.com> wrote:
Dear Nabin,

I think I've worked out how to get this working. Basically the DEFAULT Sales Manager and all other Managers don't have level 1 permissions set in the Role Permissions and when I added them manually I could then see the option. Thanks for giving me an idea on where to look.

Just to check, is it true that the default role permissions dont grant level 1 access for those Manager roles?

Thank you.


On Tuesday, August 5, 2014 12:34:15 PM UTC+8, Javier wrote:
Dear Nabin,

I tried to assign Sales Manager to a particular User ID which ONLY has the Sales Manager role but still can not see the checkbox. I have not modified any of the standard default roles. Any other clues?

FYI I am using the virtual box download with all updates performed. Thanks real much.


Javier


On Monday, August 4, 2014 8:49:01 PM UTC+8, Nabin Hait wrote:

Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.



So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.



On Aug 4, 2014, at 6:01 PM, Javier <bo…@gmail.com> wrote:



> Dear Nabin,

>

> Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.

>

> Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?

>

> Thanks real much

>

> –

> You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

> To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

> To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.

> For more options, visit https://groups.google.com/d/optout.





You received this message because you are subscribed to the Google Groups "ERPNext User's Forum" group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/98600fb1-f658-415f-8bd3-d1a55828d253%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/1cb458f7-bf3c-4c73-b34d-b78a9e37e7de%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/CAAQzbF1VVEPdjBCG6BCJJvO3Y2E%2BOeOyMEYPgeFSYqyWv1CrUA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

Hi Anand,

That worked wonders. Thanks very much Anand.



On Tuesday, August 5, 2014 9:44:51 PM UTC+8, Anand Doshi wrote:
Hi Javier,

You can do that via command line, after activating environment, using:
frappe [sitename] --reset_perms

If you are using the new bench, you can prepend the command with bench, which activates the environment for you and runs the command too:

bench frappe [sitename] --reset_perms


Thanks,
Anand.


On Tue, Aug 5, 2014 at 2:49 PM, Javier <bo…@gmail.com> wrote:
Dear Anand,

Thanks for this information. For some odd reason my default install does not have any Level 1 permissions for Sales Manager --> Sales Order or Quotation (for example). Is there a way I can completely reset the permissions for all roles and all document types?

Thank you.


Javier


On Tuesday, August 5, 2014 4:43:14 PM UTC+8, Anand Doshi wrote:
Hi Javier.

The default permissions have level 1 grants. But we don't override your permission customizations unless you explicitly reset the permissions in Role Permissions Manager.


Thanks,
Anand.



On Tue, Aug 5, 2014 at 1:41 PM, Javier <bo…@gmail.com> wrote:
Dear Nabin,

I think I've worked out how to get this working. Basically the DEFAULT Sales Manager and all other Managers don't have level 1 permissions set in the Role Permissions and when I added them manually I could then see the option. Thanks for giving me an idea on where to look.

Just to check, is it true that the default role permissions dont grant level 1 access for those Manager roles?

Thank you.


On Tuesday, August 5, 2014 12:34:15 PM UTC+8, Javier wrote:
Dear Nabin,

I tried to assign Sales Manager to a particular User ID which ONLY has the Sales Manager role but still can not see the checkbox. I have not modified any of the standard default roles. Any other clues?

FYI I am using the virtual box download with all updates performed. Thanks real much.


Javier


On Monday, August 4, 2014 8:49:01 PM UTC+8, Nabin Hait wrote:

Do not change perm level of that field, it is purposefully done. Basically, if there is any pricing rule, normal users can not bypass the rule, only Managers can bypass. And fields with perm level 1 is only visible to Manager roles in these documents.



So, if you give “Sales / Purchase / Accounts Manager” roles to “Administrator” user, you should be able to see the field.



On Aug 4, 2014, at 6:01 PM, Javier <bo…@gmail.com> wrote:



> Dear Nabin,

>

> Thanks to your suggestion I checked the field for hidden properties and although it was not hidden I noticed that the field is set to Perm Level 1. If I change it to Perm Level 0 the field is visible.

>

> Perhaps I do not understand the concept of perm level in erp next but I am using the Administrator account and I definitely cannot see the field. Should the field be set to perm level 0? Or am I making a mistake elsewhere?

>

> Thanks real much

>

> –

> You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

> To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

> To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/a0975259-eb7a-4563-b7a7-d80ecf586a90%40googlegroups.com.

> For more options, visit https://groups.google.com/d/optout.





You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/98600fb1-f658-415f-8bd3-d1a55828d253%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/1cb458f7-bf3c-4c73-b34d-b78a9e37e7de%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/c9955eec-edba-4bfe-abde-e286c8c5a5a6%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.