I installed SSL but still not secure

Hi
I installed SSL so this is shown here in the link…

1

But this message appears when trying to login to the domain

And if I put port 8000 I can access ERPNEXT as it appears here

But the domain becomes insecure.

5
What do I have to do??
Your help is appreciated
Thanks a lot

Any help??

Did you switch to DNS based setup instead of port based setup?

https://frappeframework.com/docs/v13/user/en/bench/guides/setup-multitenancy
https://frappeframework.com/docs/v13/user/en/bench/guides/configuring-https

Thank you Dear TurkerTunali For replying… I appreciate that…
look to screenshots please …
1

2

3

4

5

I think the problem in nginx reload… What you think ?

What does “sudo service nginx status” show?

How did you installed ERPNext? Which OS is this?

Dear TurkerTunali…
Thank you very much for replying, I appreciate that …
I reinstall ERPNEXT again I used Ubuntu 20.04… I Installed it by my self…
I have made screenshots of the SSL install steps and they are all in front of you now…
1…
1

2…
2

3…
3

4…
4

5…
5

6…
6

What does “sudo service nginx status” show?
7

until now I can access to my domain new7.-----.com:8000 But it is not secure … If I write https://new7.-----.com I will see …
8

I hope you have the perfect solution …
Thank you very much

In this article, I have explained in the last section the method to configure an SSL certificate.
Using these steps I have done more than 30 installations without error. So I have provided the step-by-step guide in this article.

I would try this.

  • Create a new site.
  • Access it in the browser.
  • If everything works well then I would try to install SSL certificate.

For a DNS based setup it should use port 80 and 443. Not 8000.

Yes dear AmjidAli and TurkerTUNALI… I created site. I can access it in browser

and I installed the SSL certificate …
2

But when try to access https:/— I saw
8

so… What is left until I can access the site safely??
Thanks all

You are confusing yourself with having a website run on a different port number and using SSL

SSL is used on 443 and what I see is you have to clean the whole setup.

Move site to 80 or 443 port.
then let certbot create the certificate for you and update the nginx config, you should do it manually only when you know what your doing and for that nginx config understanding is needed.

From your thread, I see that your certificate which is generated is assigned in the default config to the domain name that you linked it to while your site is on different port. Which means there are 2 configuration for nginx

  1. which is for ssl cert
  2. For site using port 8000

If you need to make use of automated tools then enable multi-tenant on bench.

well documented here.
Good Luck.

May be install as per this site… I used it and worked fine. Try it. How to deploy ERPNext 13 on Ubuntu 20.04 LTS (Focal Fossa)