I have just dep0loyed a baremetal remote Debian server anyone wonna install EPRNEXT

Hi,
I have a bare metal debian 8,. Is there anyone who would like to install debian there to troubleshoot. lol

Offer valid for only today 2/3/2016

Seriously one should install and document for others to follow.

@Peter_Muchora
Do you want to install ERPNext there?, send me ssh details on private message

As per https://github.com/frappe/bench , ERPNext Supported for CentOS 6, CentOS 7, Debian 7 and Ubuntu 12.04+

Also I have installed several time on Ubuntu 14.04 LTS

If you have Ubuntu 14.04 server, I can install ERPNext within 15 min(depending on server speed)

It is debian 8 is it supported.

@Peter_Muchora
I have not tried on debian 8, but if you can give ubuntu 14.04 or CentOS 6, CentOS 7,Debian 7 then we need to run only two commands

wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh --setup-production

Yes I am able to do that on ubuntu but Debian 8 is a problem.

I need someone who has succeeded with it.

@Peter_Muchora why the need for Debian 8?

@Peter_Muchora you can install on Debian 8, but for this you need to install all dependency manually

Check Install pre-requisites - https://github.com/frappe/bench

Stuck at installing mariadb
The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-10.1 (= 10.1.12+maria-1~sid) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Though this problem was resolved in mariadb 5.5 but it seems it is still there

Any ideas

If I am not mistaken there are 2 packages required by ERPNext 6.x which are not available in deb 7 wheezy. Forgot which 2 though.

My experiments with a docker installation so far only worked with ubuntu really

The Debian 8 Maria DB install instructions are located here:
https://downloads.mariadb.org/mariadb/repositories/#mirror=digital-pacific&distro=Debian&distro_release=sid--sid&version=10.1

sudo apt-get install software-properties-common
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xcbcb082a1bb943db
sudo add-apt-repository ‘deb [arch=amd64,i386] http://mariadb.mirror.digitalpacific.com.au/repo/10.1/debian sid main’
Once the key is imported and the repository added you can install MariaDB with:

sudo apt-get update
sudo apt-get install mariadb-server
See Installing MariaDB .deb Files for more information.

Installing the .deb Files Manually
While it is not recommended, it is possible to download and install the packages manually (i.e. without a package manager like apt-get).

If you still have MariaDB issues remove your existing MariaDB install/dependencies and try installing again.

Done this a hundred times. Eventually I will succeed but what about those who are not so IT savy.

I will use the server for other purposes too

That’s the damn thing with giving names AND numbers

wheezy, squeeze, sid, 7, 8 ???

At least I am pretty certain that ‘sid’ always is the unstable of debian. At least I meant the current stable realease which I think should be 8?

jessie is debian 8. It is stable. Sid is 9 unstable.

What I get after installing some manually

~# sudo bash setup_frappe.sh --setup-production
Installing for debian 8 amd64
In case you encounter an error, you can post on https://discuss.frappe.io

Adding debian mariadb repo
Installing packages for debian. This might take time…
Reading package lists…
Building dependency tree…
Reading state information…
fontconfig is already the newest version.
fontconfig set to manually installed.
libxext6 is already the newest version.
libxext6 set to manually installed.
libxrender1 is already the newest version.
libxrender1 set to manually installed.
postfix is already the newest version.
redis-server is already the newest version.
vim is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libmariadbclient-dev : Depends: libmariadbclient18 (>= 10.1.12+maria-1~sid) but it is not going to be installed
mariadb-server : Depends: mariadb-server-10.1 (= 10.1.12+maria-1~sid) but it is not going to be installed
nodejs : Conflicts: npm
python-mysqldb : Depends: libmysqlclient18 (>= 5.5.24+dfsg-1) but it is not goi ng to be installed
E: Unable to correct problems, you have held broken packages.

@Peter_Muchora I have only used CentOS7 and Ubuntu so could be totally wrong. Apologies if I am.
From the failed install logs it looks like you need to install node and NPM before
~# sudo bash setup_frappe.sh --setup-production
After a failed frappe install make sure you remove mySQL/Maria DB elements before trying again.

After installing all the prerequisites listed on the Github page, Reboot Debian before attempting Frappe install.
You can read what is going on in setup_frappe.sh by visiting the setup_frappe.sh URL in your web browser. It might need a slight modification for Debian. HTH

~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 8.3 (jessie)
Release: 8.3
Codename: jessie
:~#
:~# lsb_release -aNo LSB modules are available.^C
:~# uname -mrs
Linux 3.16.0-4-amd64 x86_64