I have a problem with the 2 decimals in the incoming_rate field in stock entry and in purchase order

Can I change that to 3 decimals so the system would not round the price as this happens with big quantities that causes huge amount difference ?





You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To post to this group, send email to er...@googlegroups.com.

To unsubscribe from this group, send email to erpnext-developer-forum+un...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msg/erpnext-developer-forum/-/nP4JUDVqJxoJ.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

Hi HF,


You can try changing the fieldtype of incoming rate from currency to float using Setup > Customize Form.
Float has 6 decimal precision. Currently there is no easy way to specify a desired precision. Either it is 2 or 6.

In case of Stock Entry, go to Customize Form, select doctype - Stock Entry Detail and change fieldtype of field incoming_rate to float. Then click on the update button at the top of the form.


Similarly, change it for DocType Stock Ledger Entry - fieldname incoming_rate
(as it is the backend entry made on the submission of Stock Entry, Purchase Receipt and Delivery Note.)

You can do this with any field where you require more precision.

Thanks,
Anand.

On Thu, Oct 11, 2012 at 6:31 PM, HF <h....@gmail.com> wrote:
Can I change that to 3 decimals so the system would not round the price as this happens with big quantities that causes huge amount difference ?





You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To post to this group, send email to er…@googlegroups.com.

To unsubscribe from this group, send email to erpnext-developer-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msg/erpnext-developer-forum/-/nP4JUDVqJxoJ.

For more options, visit https://groups.google.com/groups/opt_out.








You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To post to this group, send email to er...@googlegroups.com.

To unsubscribe from this group, send email to erpnext-developer-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

Hi Anand;


Thanks,
That’s fine it works.



You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To post to this group, send email to er...@googlegroups.com.

To unsubscribe from this group, send email to erpnext-developer-forum+un...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msg/erpnext-developer-forum/-/1E_4kSANpIwJ.

For more options, visit https://groups.google.com/groups/opt_out.