I Cant install a new app/module in my site

Good day sir,

          I have a problem in  installing the website chat in my site.... when I press the install button it says "Not Permitted"....  I tried a few ways like remaking it.. but it still says the said error.... what could be the problem... Thank you and god bless

Website chat is not updated for a while. Sorry for that!

is that so… thanks for the info… but umm are there any other api’s or apps that I can install in my site? I also heard that Library System is also not updated…

This is not very organized yet, maybe we will get to it after version 5. You should stick to the ones listed at https://frappe.io/community/apps

Umm how caan I install it… can you give me a guide sir… I’m confused… thank you

I cant also install Base Vat same error pops out… It says “Not Permitted” also

Can you share the full trace?

cc @luisfmfernandes

I installed it, but the issue is when I installed it I cant add new customers

Well. I have a solution but i don’t know why is this happening!

I think this will solve the problem, just run bench frappe --latest.

For the erpnext team: when we install apps is not suppose to create the custom fields in db?

When i install base_vat, frappe created everything except the custom fields in db and then when i run bench frappe --latest he created the db custom fields…this in version 5.

So, i think this problem is only occurring in Version 5.

Have you added the custom fields as fixtures? https://frappe.io/kb/app-development/how-to-add-customizations-to-app

Yes, like this:

fixtures = [
"Custom Field",
"Custom Script"

]
And it works in version 4 but in version 5 does’t work. I mean it install every thinks and every think seems to be working. It just don’t make the db fields.

And, when i made bench frappe --latest the db fields were created.

i tried to migrate to version 5, it said an error the when I tried to access the frappe desk its says internal service error