How to uncheck ((Custom?)) from DocType?

I’m Trying to create an app, of course I started with creating DocType, but the problem is how can I unchecked Custom? here?

I clicked many times but nothing changed, and yes I’m login as an administrator

by the way I’m using Ubuntu 16

But why do you want to un check it? I believe since its a custom form you making is for your specific needs, it needs to be flagged like that, else it will get lost when you do version upgrade.

Btw, have you read something in documentation about benefits of removing the ‘Custom’ flag?

No I did not … But my friend told that I can not use .py files in my app while Custom? is checked

The folder doctype is not present even after creating the doctypes.
After exploring I came to know that doctype will be visible only after unchecking the custom? box.

for this developer_mode has to be on too.

image

1 Like

Thank you.
I am able to uncheck the custombox now but the folder doctype is not there.

check your developer_mode in

site_config.json

1 Like

Got it. Thanks :smiley:

I’m having the same issue. I downloaded a custom app from a repository. my developer mode is on but I’m still unable to uncheck the “custom?” checkbox.
Why do I want to do that? Same reason someone else posted already: So it will generate a doctype folder with customizable client and serverside code.

try to
bench build && bench clear-cache

If you have created a doctype to be “custom” you will have to duplicate it (as this is a set only once field). While the form with the duplicate is open, delete the former “custom” doctype (to make the name available) and then save the duplicate… And do not forget to be logged in as the Administrator to do this…

1 Like

This is the fix right here! I was not logged in as Administrator. I thought it would be sufficient if my account had proper permissions, but that was not the case. So all of the above & logging in as admin should do the trick.

3 Likes

Damn wasted more than an hour to find this solution. Was logged in as other user not as Admin.

Hi ERPNext Community,

I am new to ERPNext and Frappe family. I am facing the same problem.
I have checked in site_config.json file, the developer mode is 1. Moreover, I logged in as administrator but still I am not able to uncheck custom option from doctype.

When you make changes directly the config file, you should run bench migrate.

However, for others, you can run bench set-config developer_mode 1 from the bench :slight_smile:

How where you able to uncheck the custom?

When I create a custom doctype there I want to uncheck the custom option. I have already enabled the developer mode and logged in as an administrator, but the custom option is still disabled. I am using nginx. Is it because of nginx? I find every possible thing but nothin is working. Can anyone tell what am I doing wrong?


2

I used bench set-config developer_mode 1 then cleared cache and was able to uncheck the custom.