How to Skip Draft State - Go Directly to First Workflow State?

I have created a “Widget Request” doctype. All users have the ability to create a new “Widget Request” and save it. When users save the Request, it goes into the “Draft” state.

I don’t want new document to go into Draft state. Instead I want to have the saved document go directly to a workflow state called “Pending Approval” where it is no longer editable to original user. Only a special Approver role can edit it in pending state.

I can’t figure out how to skip the Draft state and go directly to the Pending Approval state.

The point of this is that I don’t want the original user to have to click “Save” and then also click “Submit Request” as an additional step to submit it for approval. User should fill out form, click “Save” or “Submit” or something once and be done.

If I try to leave out the “Draft” state in the Workflow, the Workflow warns me that Draft is missing from the states. And if I try to create a document and save it, it won’t save properly due to the absence of draft state; it throws an error that says " Workflow State transition not allowed from Pending Approval to Draft"

How can I skip Draft state and go directly to the “Pending Approval” workflow state when the form is first created?

Can you share a snip shot of your workflow on Widget Request

As you can see, I intentionally omitted “draft” state. I don’t want a draft state. Upon first-time save/creation of document, I want it to go immediately to Pending.

  1. This should be unchecked.
    image
  2. It is only a warning you can still proceed with the saving, else you can delete first the draft documents before creating the workflow.
1 Like

Just like @tdci mentioned. Go ahead and save anyways.

It turns out you have created two document already before you activated your new workflow. You have two option.

  1. Delete existing document in draft and create it over again.

  2. a. Add a document rule called draft on your workflow
    b. Put in a new transition from draft to pending on your workflow
    c. Go back to “Widget Request” and change the status of the two request to pending.
    d. Go to your work flow and take out “a” and “b”

1 Like

Thank you guys!

I didn’t realize the error being shown was talking about documents that had already been created. I was able to clear everything up now, and new documents save directly to Pending state!