How to retrieve my backup files from corrupted erpnext in Oracle Virtual box running on Windows

Yes I did notice and the issues seems to be with your network and how its setup, which is why lets try the reboot steps first and go from there

1 Like

VM is booting up.

Even localhost:8080 doesnot work

It all started after I upgraded from ErpNext 8 to 9

I think the version of node.js is not supported by ERPNext 9

I don’t think the issue is node. What is the IP address of eth0 now?

1 Like

localhost:8080 will only work if you are running local on the VM. it will not work if you try to access from the PC

1 Like

Yes I am on the local on the VM on the Local PC. It was working perfectly before upgradation.with localhost:8080

So what is the network address you are getting now when you do ifconfig

1 Like

same like before. 127.0.0.1

What is the IP on your PC and what are the network settings there?

1 Like

Microsoft Windows [Version 10.0.14393]
© 2016 Microsoft Corporation. All rights reserved.

C:\Users\Amar>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Amar-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : E8-03-9A-A1-D8-21
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter VirtualBox Host-Only Network:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
Physical Address. . . . . . . . . : 0A-00-27-00-00-03
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::c1e9:1b04:4659:858e%3(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 621412391
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-96-5C-FD-B8-03-05-6F-E2-A3
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Local Area Connection* 13:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Hosted Network Virtual Adapter
Physical Address. . . . . . . . . : B8-03-05-6F-E2-A4
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : B8-03-05-6F-E2-A7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Centrino® Wireless-N 130
Physical Address. . . . . . . . . : B8-03-05-6F-E2-A3
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::fc0a:fca3:9072:923d%7(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.109(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 06 September 2017 16:42:26
Lease Expires . . . . . . . . . . : 09 September 2017 16:42:30
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 330826501
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-96-5C-FD-B8-03-05-6F-E2-A3
DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{17D6281C-5039-4ECA-B4FE-8442DE91DA8D}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 4:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:34ac:d7e7:8a31:3206(Preferred)
Link-local IPv6 Address . . . . . : fe80::34ac:d7e7:8a31:3206%23(Preferred)
Default Gateway . . . . . . . . . : ::
DHCPv6 IAID . . . . . . . . . . . : 402653184
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-96-5C-FD-B8-03-05-6F-E2-A3
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{06A1541D-E547-4CC1-91B1-B417086D1EE2}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\Users\Amar>

So ipv4 for ethernet is
192.168.137.1

and ipv4 for wifi is
192.168.1.109

Please note that of VM Manager I am unable to see en1 and en0 settings

8

Based on the screengrab you sent earlier what you are seeing is correct. However, instead of using the Wireless adapter change it to the Ethernet Adapter. Also shutdown the VM, change the adapter, than boot your vm

1 Like

You mean under the bridged adapter where there are 4 names?

  1. Intel ® centrino ® Wireless N130
  2. Microsoft virtual wifi miniport adaptor # 2
  3. Microsoft virtual wifi miniport adaptor
  4. Realtek PCIs GBE family controller

If not then please tell me where can I find Wireless adaptor settings so that I can change it to Ethernet Adaptor

thanks @saidsl

Yes select the above

1 Like

OK I selected it

VM is being restarted.

When It was starting the top line said

[92.some number?] no valid rapl. found…

Then Ubuntu 14.04

Waiting for network configuration

Then
waiting upto 60 more seconds for network configuration

Then
Starting system without full network configuration…

Have you assigned an IP already for the VM? i noticed that you had an ip already in the network details that you send earlier.

1 Like

I don’t understand how to assign IP for VM

What do you get if you enter this

http://192.168.137.1:8080 on your PC browser

1 Like

site can not be reached

@Amarjeet_Singh_Sintu

As much as I would like to be able to solve the problem you have, Its hard to pin point it this way.

The only thing I can offer and if you are willing to do so, is if you would like to export your vm and upload the exported file and then I can backup what you need and send you the sql file so you can restore it on a new VM or whereever you would like to

Its your choice

1 Like