ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

How to minimize Dashboard permanantly


#1

Hi All,

How I can minimize “dashboard” permanently in Customer.

Regards,
Satish Aralkar


#2

Let me help you remove it permanently. I’m also not able to minimize that but Yes, I can hide it completely.

Log into Terminal and do following things.

  1. cd /home/frappe/frappe-bench/apps/erpnext/erpnext/selling/doctype/customer/
  2. nano customer_dashboard.py and you will get something like this. At the top of page:

def get_data(): return { 'heatmap': True,
Do a small change, just change “True” to value "False"
def get_data(): return { 'heatmap': False,

and Yes, Don’t forget to hit bench commands. Hit one by one.

bench setup redis
bench clear-cache
sudo supervisorctl restart all
bench build

and yes, follow the same where you find this heatmap.


#3

@aaimaa, Thanks for your reply. This worked for me.

I was looking for the standard setup in DocType. I hope this will be added in DocType setting.


#4

Hi!
Did you find any way to minimize the dashboard? I don’t want to hide completely, I need the user can click on dashboard and see it …

Regards


#5

@anibal.duardo, I did not find the standard setting. Actually what I was looking for is , on form open, dashboard should be minimized so that user can fill-up form without scrolling.

This feature should be available in Doctype setting.


#6

Currently its not the feature yet… But using custom app, you can modify dashboard.js under frappe/public/js folder and run bench build


#7

Try this @anibal.duardo in your JavaScript (could be a Custom Script in case of a Standard DocType)

frappe.ui.form.on("Item", {
    refresh: function(frm) {
        frm.dashboard.wrapper.parent().addClass("hide")
            .parent().find(".section-head").addClass("collapsed")
            .find(".octicon.collapse-indicator.octicon-chevron-up")
            .removeClass()
            .addClass("octicon collapse-indicator octicon-chevron-down") 
    }
})

#8

#9

Hi,

This really should be available in DocType Setting / Customize Form by default. It can be quite an inconvenience and should be optional! I created a Github issue for it over 2 months ago. Hopefully it’ll be fixed sometime soon

Cheers!


#10

put this in your custom script

cur_frm.dashboard.frm.fields[0].df.collapsible=0