How to install ERPNext 13?

Hello Community…
I m Frustet to install erpnext installation So many errors…
Have any idea to erpnext 13 installation.
Erpnext 13 because my past backup from erpnext 13 and now my running VM is showing an error when I update.
Kindly provide a solution fast.
My business depends on erpnext.

Hello,

Did you try this.

-OR-

TIA

Yogi Yang

Thanks…
will try and update.

I have tried this method…
I think the installation is done successfully. but when i entered the command bench start then it while taking more time than usual.
and


this error…

At your frappe bench type
bench setup nginx and then
bench start

Tried but not success.

Hello,

Did you set the site as default?

bench use dcode.com

Here replace dcode.com with the name of the site that you created.

TIA

Yogi Yang

no…
i was used my site name

Please provide more information. These short responses is not giving a better picture of what is happening.

Hello,

Sorry I don’t understand as to what you are saying.

Please give detailed reply.

TIA

Yogi Yang

when i create a site
Command

bench new-site site1.local

site1.local is my site name.
show me this


FOLLOW THIS INSTALLATION STEPS. USE VERSION-13 INSTEAD OF 14

1 Like

I think it successfully installs with your this script

https://github.com/D-codE-Hub/ERPNext-installation-Guide

but web browser can not connect with my erpnext,

now i can show this page whan I search with my IP.


and setup was successfully installed.

i think I m near…

now how to slow this…

1 Like

Success fully installed and connect via web browser successfully.

frp.teci.in:8000

but want to

frp.teci.in   only

and also add let’s encrypt SSL certificate.

I’m trying to install V13, so i did as you said to change to ver 13 when installing

when ini the frappe i got this error “bench init frappe --verbose --frappe-branch v13.41.4”

error /home/bench/frappe/apps/frappe/node_modules/node-sass: Command failed.
Exit code: 1
Command: node scripts/build.js
Arguments:
Directory: /home/bench/frappe/apps/frappe/node_modules/node-sass
Output:
Building: /usr/bin/node /home/bench/frappe/apps/frappe/node_modules/node-gyp/bin/node-gyp.js re                               build --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library=
gyp info it worked if it ends with ok
gyp verb cli [
gyp verb cli   '/usr/bin/node',
gyp verb cli   '/home/bench/frappe/apps/frappe/node_modules/node-gyp/bin/node-gyp.js',
gyp verb cli   'rebuild',
gyp verb cli   '--verbose',
gyp verb cli   '--libsass_ext=',
gyp verb cli   '--libsass_cflags=',
gyp verb cli   '--libsass_ldflags=',
gyp verb cli   '--libsass_library='
gyp verb cli ]
gyp info using node-gyp@3.8.0
gyp info using node@16.17.1 | linux | x64
gyp verb command rebuild []
gyp verb command clean []
gyp verb clean removing "build" directory
gyp verb command configure []
gyp verb check python checking for Python executable "python2" in the PATH
gyp verb `which` failed Error: not found: python2
gyp verb `which` failed     at getNotFoundError (/home/bench/frappe/apps/frappe/node_modules/wh                               ich/which.js:13:12)
gyp verb `which` failed     at F (/home/bench/frappe/apps/frappe/node_modules/which/which.js:68                               :19)
gyp verb `which` failed     at E (/home/bench/frappe/apps/frappe/node_modules/which/which.js:80                               :29)
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/which/which.js:89:16
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/index.js:42:5
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/mode.js:8:5
gyp verb `which` failed     at FSReqCallback.oncomplete (node:fs:206:21)
gyp verb `which` failed  python2 Error: not found: python2
gyp verb `which` failed     at getNotFoundError (/home/bench/frappe/apps/frappe/node_modules/wh                               ich/which.js:13:12)
gyp verb `which` failed     at F (/home/bench/frappe/apps/frappe/node_modules/which/which.js:68                               :19)
gyp verb `which` failed     at E (/home/bench/frappe/apps/frappe/node_modules/which/which.js:80                               :29)
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/which/which.js:89:16
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/index.js:42:5
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/mode.js:8:5
gyp verb `which` failed     at FSReqCallback.oncomplete (node:fs:206:21) {
gyp verb `which` failed   code: 'ENOENT'
gyp verb `which` failed }
gyp verb check python checking for Python executable "python" in the PATH
gyp verb `which` failed Error: not found: python
gyp verb `which` failed     at getNotFoundError (/home/bench/frappe/apps/frappe/node_modules/wh                               ich/which.js:13:12)
gyp verb `which` failed     at F (/home/bench/frappe/apps/frappe/node_modules/which/which.js:68                               :19)
gyp verb `which` failed     at E (/home/bench/frappe/apps/frappe/node_modules/which/which.js:80                               :29)
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/which/which.js:89:16
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/index.js:42:5
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/mode.js:8:5
gyp verb `which` failed     at FSReqCallback.oncomplete (node:fs:206:21)
gyp verb `which` failed  python Error: not found: python
gyp verb `which` failed     at getNotFoundError (/home/bench/frappe/apps/frappe/node_modules/wh                               ich/which.js:13:12)
gyp verb `which` failed     at F (/home/bench/frappe/apps/frappe/node_modules/which/which.js:68                               :19)
gyp verb `which` failed     at E (/home/bench/frappe/apps/frappe/node_modules/which/which.js:80                               :29)
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/which/which.js:89:16
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/index.js:42:5
gyp verb `which` failed     at /home/bench/frappe/apps/frappe/node_modules/isexe/mode.js:8:5
gyp verb `which` failed     at FSReqCallback.oncomplete (node:fs:206:21) {
gyp verb `which` failed   code: 'ENOENT'
gyp verb `which` failed }
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variabl                               e.
gyp ERR! stack     at PythonFinder.failNoPython (/home/bench/frappe/apps/frappe/node_modules/no                               de-gyp/lib/configure.js:484:19)
gyp ERR! stack     at PythonFinder.<anonymous> (/home/bench/frappe/apps/frappe/node_modules/nod                               e-gyp/lib/configure.js:406:16)
gyp ERR! stack     at F (/home/bench/frappe/apps/frappe/node_modules/which/which.js:68:16)
gyp ERR! stack     at E (/home/bench/frappe/apps/frappe/node_modules/which/which.js:80:29)
gyp ERR! stack     at /home/bench/frappe/apps/frappe/node_modules/which/which.js:89:16
gyp ERR! stack     at /home/bench/frappe/apps/frappe/node_modules/isexe/index.js:42:5
gyp ERR! stack     at /home/bench/frappe/apps/frappe/node_modules/isexe/mode.js:8:5
gyp ERR! stack     at FSReqCallback.oncomplete (node:fs:206:21)
gyp ERR! System Linux 5.15.0-1021-aws
gyp ERR! command "/usr/bin/node" "/home/bench/frappe/apps/frappe/node_modules/node-gyp/bin/node                               -gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--lib                               sass_library="
gyp ERR! cwd /home/bench/frappe/apps/frappe/node_modules/node-sass
gyp ERR! node -v v16.17.1
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok


Traceback (most recent call last):
  File "/usr/local/lib/python3.10/dist-packages/bench/commands/make.py", line 68, in init
    init(
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/render.py", line 105, in wrapper_fn
    return fn(*args, **kwargs)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/system.py", line 79, in init
    get_app(
  File "/usr/local/lib/python3.10/dist-packages/bench/app.py", line 432, in get_app
    app.install(verbose=verbose, skip_assets=skip_assets, restart_bench=restart_bench)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/render.py", line 126, in wrapper_fn
    return fn(*args, **kwargs)
  File "/usr/local/lib/python3.10/dist-packages/bench/app.py", line 230, in install
    install_app(
  File "/usr/local/lib/python3.10/dist-packages/bench/app.py", line 569, in install_app
    bench.run("yarn install", cwd=app_path)
  File "/usr/local/lib/python3.10/dist-packages/bench/bench.py", line 47, in run
    return exec_cmd(cmd, cwd=cwd or self.cwd)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/__init__.py", line 155, in exec_cmd
    raise CommandFailedError
bench.exceptions.CommandFailedError

ERROR: There was a problem while creating frappe